summaryrefslogtreecommitdiff
path: root/dev-python
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-12 16:55:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-12 21:20:23 +0200
commite7c8f34bd20cf0421aba55f1f03fd5478679583b (patch)
tree6e2e3b5d2f73b75b51c9fde2f78b7bca994e1e5f /dev-python
parentc7a5ad132b16f3b8e7de33cae162405444442d30 (diff)
downloadgentoo-e7c8f34bd20cf0421aba55f1f03fd5478679583b.tar.gz
gentoo-e7c8f34bd20cf0421aba55f1f03fd5478679583b.tar.xz
dev-python/rospkg: Bump to 1.1.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/rospkg/Manifest1
-rw-r--r--dev-python/rospkg/rospkg-1.1.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/rospkg/Manifest b/dev-python/rospkg/Manifest
index 20f45e721c4..a0240b37ae5 100644
--- a/dev-python/rospkg/Manifest
+++ b/dev-python/rospkg/Manifest
@@ -1 +1,2 @@
DIST rospkg-1.1.0.tar.gz 89282 SHA256 e1a7c0025c565a969a32d75407f4fc9ae51c0676a40aa0d86c65cac7779fc760 SHA512 0b38eb9fec701ff27842870c4d089f2deede1558f41a02004a8f2eb3fb639dac9c744086794f756b94dc108483ca433ffe4bff33be3031f496e90059f3f5c65b WHIRLPOOL 5c89ef46a0e5372725617f17ef3cf5daa474ed6de1c57884e6b1e49069f93d2aebfe6a176ecb0ae5c8d69def5091432b99b481d81b0d69893fb53c3dce9360f6
+DIST rospkg-1.1.1.tar.gz 89468 SHA256 193a23db79c72809666f8821399c1118ca18eaa8b6b248acfe27632a17878ccd SHA512 73c29d9402140793b038f7e831fe38078ee359a77baa319f54d1b1587bb4b899c28073970e591ecaba4fbd5897c455d419d0f68f7179da5655da020bfc08b83c WHIRLPOOL 8fc8affc523f51e9f44bbb91a699bc8411086b5e9787964a2edd41b33a847ccdd294c992ded7bf4a8cf52740fdde360908e3a570c384d3a54a68a09c06a80d6d
diff --git a/dev-python/rospkg/rospkg-1.1.1.ebuild b/dev-python/rospkg/rospkg-1.1.1.ebuild
new file mode 100644
index 00000000000..dff594067af
--- /dev/null
+++ b/dev-python/rospkg/rospkg-1.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/ros-infrastructure/rospkg"
+fi
+
+inherit ${SCM} distutils-r1
+
+DESCRIPTION="Standalone Python library for the ROS package system"
+HOMEPAGE="http://wiki.ros.org/rospkg"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SRC_URI=""
+ KEYWORDS=""
+ # Needed for tests
+ S="${WORKDIR}/${PN}"
+ EGIT_CHECKOUT_DIR="${S}"
+else
+ SRC_URI="https://github.com/ros-infrastructure/rospkg/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/gentoo.patch" )
+
+python_test() {
+ nosetests --with-coverage --cover-package=rospkg --with-xunit test || die
+}