summaryrefslogtreecommitdiff
path: root/dev-qt/qt-docs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-qt/qt-docs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-qt/qt-docs')
-rw-r--r--dev-qt/qt-docs/Manifest2
-rw-r--r--dev-qt/qt-docs/metadata.xml9
-rw-r--r--dev-qt/qt-docs/qt-docs-5.4.2_p0.ebuild32
-rw-r--r--dev-qt/qt-docs/qt-docs-5.5.0_p0.ebuild32
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-qt/qt-docs/Manifest b/dev-qt/qt-docs/Manifest
new file mode 100644
index 00000000000..1c3aed7ecc0
--- /dev/null
+++ b/dev-qt/qt-docs/Manifest
@@ -0,0 +1,2 @@
+DIST 5.4.2-0qt5_docs.7z 78495429 SHA256 c2ac1a18467a0fbb1d2504d78085e6c0d4901442d79895894fcc078fb310c719 SHA512 9e13b1f3e7daa38e91695d193bc67c3ddcc2d0d86febd6c53b4045bebbae7e97171c30990ba702440597861fdcfe780a177918fa334f190970dc933985cb55ff WHIRLPOOL 531521c00af6be74d2b1c4ad782f43cdae8fe8dfe67863582e8672342bd2df653f682fe5aeeb4782c302cf4074d4abe5d1a4356a07899725b062790d58bb1d46
+DIST 5.5.0-0qt5_docs.7z 83725712 SHA256 673ec0493b95cb16fed7600d27dd29478c419a370323f7fda4a8900ffa3c813e SHA512 e3cda1ae5b64ce9cc391f15683621d21c2075cf7bd861a485555d70b25e706c37c64f62d940390c2ae73ed21b1cdb87f1fb643b45d51e42116a048d4e5b14fe5 WHIRLPOOL 007b80b832f9db6691bde1d7fc071eaca54d60515764ab6a181c7d78108d6f9a1709dd44cda14de453f0258fd87006db830713e5212e60784a4921ab8be5c982
diff --git a/dev-qt/qt-docs/metadata.xml b/dev-qt/qt-docs/metadata.xml
new file mode 100644
index 00000000000..b41982b9d58
--- /dev/null
+++ b/dev-qt/qt-docs/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>http://doc.qt.io/</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-qt/qt-docs/qt-docs-5.4.2_p0.ebuild b/dev-qt/qt-docs/qt-docs-5.4.2_p0.ebuild
new file mode 100644
index 00000000000..e1171d51a55
--- /dev/null
+++ b/dev-qt/qt-docs/qt-docs-5.4.2_p0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator
+
+MY_PV=$(get_version_component_range 1)$(get_version_component_range 2)
+
+DESCRIPTION="Documentation for Qt5, for use with Qt Creator and other tools"
+HOMEPAGE="https://www.qt.io/"
+SRC_URI="http://download.qt.io/online/qtsdkrepository/linux_x64/desktop/qt5_${MY_PV}_src_doc_examples/qt.${MY_PV}.doc/${PV/_p/-}qt5_docs.7z"
+
+LICENSE="FDL-1.3"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/p7zip"
+
+S=${WORKDIR}/Docs/Qt-$(get_version_component_range 1-2)
+
+src_install() {
+ # remove global docs that conflict with qtcore
+ rm -rf global
+
+ # ${PV} instead of ${PF} is intentional
+ local dest=/usr/share/doc/qt-${PV%%_p*}
+ insinto "${dest}"
+ doins -r *
+ docompress -x "${dest}"
+}
diff --git a/dev-qt/qt-docs/qt-docs-5.5.0_p0.ebuild b/dev-qt/qt-docs/qt-docs-5.5.0_p0.ebuild
new file mode 100644
index 00000000000..e1171d51a55
--- /dev/null
+++ b/dev-qt/qt-docs/qt-docs-5.5.0_p0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit versionator
+
+MY_PV=$(get_version_component_range 1)$(get_version_component_range 2)
+
+DESCRIPTION="Documentation for Qt5, for use with Qt Creator and other tools"
+HOMEPAGE="https://www.qt.io/"
+SRC_URI="http://download.qt.io/online/qtsdkrepository/linux_x64/desktop/qt5_${MY_PV}_src_doc_examples/qt.${MY_PV}.doc/${PV/_p/-}qt5_docs.7z"
+
+LICENSE="FDL-1.3"
+SLOT="5"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="app-arch/p7zip"
+
+S=${WORKDIR}/Docs/Qt-$(get_version_component_range 1-2)
+
+src_install() {
+ # remove global docs that conflict with qtcore
+ rm -rf global
+
+ # ${PV} instead of ${PF} is intentional
+ local dest=/usr/share/doc/qt-${PV%%_p*}
+ insinto "${dest}"
+ doins -r *
+ docompress -x "${dest}"
+}