summaryrefslogtreecommitdiff
path: root/dev-qt/qtbearer
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-qt/qtbearer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-qt/qtbearer')
-rw-r--r--dev-qt/qtbearer/Manifest3
-rw-r--r--dev-qt/qtbearer/metadata.xml13
-rw-r--r--dev-qt/qtbearer/qtbearer-4.8.5.ebuild58
-rw-r--r--dev-qt/qtbearer/qtbearer-4.8.6-r1.ebuild47
-rw-r--r--dev-qt/qtbearer/qtbearer-4.8.7.ebuild44
5 files changed, 165 insertions, 0 deletions
diff --git a/dev-qt/qtbearer/Manifest b/dev-qt/qtbearer/Manifest
new file mode 100644
index 00000000000..ac4ca6af0d2
--- /dev/null
+++ b/dev-qt/qtbearer/Manifest
@@ -0,0 +1,3 @@
+DIST qt-everywhere-opensource-src-4.8.5.tar.gz 241491467 SHA256 eb728f8268831dc4373be6403b7dd5d5dde03c169ad6882f9a8cb560df6aa138 SHA512 47118d1aa30c59a1eb74e805023cd060edcb35bb0944fe6651889254b75acbd4b83700ba92a9bc215663474d26330cb44f084098c380fac9270742659e5864eb WHIRLPOOL a18f47fd91b522d1543e415aff4f5056202e0cab03da9cfcae9fe2d4118cb1dd1d5fd6a5e2edb9c1e4a68563188d44440e234d268d9c0aef6e3ca3f0988dd357
+DIST qt-everywhere-opensource-src-4.8.6.tar.gz 241623667 SHA256 8b14dd91b52862e09b8e6a963507b74bc2580787d171feda197badfa7034032c SHA512 c2d07c3cf9d687cb9b93e337c89df3f0055bd02bc8aa5ecd55d3ffb238b31a4308aeabc3c51a4f94ac76a1b00796f047513d02e427ed93ae8dd99f836fff7692 WHIRLPOOL 473566814a77237dbdd37a47980c1085f6cf39599c4d6b0120959fe80dadf65c4eaafd5f528dd86cea8815562faa204bedfe3b766c2ca4f2d2c99efc21dbca84
+DIST qt-everywhere-opensource-src-4.8.7.tar.gz 241075567 SHA256 e2882295097e47fe089f8ac741a95fef47e0a73a3f3cdf21b56990638f626ea0 SHA512 f9f81a2e7205e1fd05c8d923dc73244f29aa33f951fa6b7c5c8193449328b37084796b9b71ad0c317e4e6fd00017c10ea5d67b1b2032551cde00548522218125 WHIRLPOOL ad8f01172f5bdb3a3a69fe7b03862c4c411bc8d95211053ad66ed1d60a3c0577d073d1075a1e0a80b25d9b2721addda55a2967e6ccf5e194cec8d08770ac5fc2
diff --git a/dev-qt/qtbearer/metadata.xml b/dev-qt/qtbearer/metadata.xml
new file mode 100644
index 00000000000..258aee1d6e0
--- /dev/null
+++ b/dev-qt/qtbearer/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>qt</herd>
+ <use>
+ <flag name="exceptions">Add support for exceptions - like catching them
+ inside the event loop (recommended by upstream)</flag>
+ </use>
+ <upstream>
+ <bugs-to>https://bugreports.qt.io/</bugs-to>
+ <doc>http://doc.qt.io/</doc>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-qt/qtbearer/qtbearer-4.8.5.ebuild b/dev-qt/qtbearer/qtbearer-4.8.5.ebuild
new file mode 100644
index 00000000000..12788696a2f
--- /dev/null
+++ b/dev-qt/qtbearer/qtbearer-4.8.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit qt4-build
+
+DESCRIPTION="The network bearer plugins for the Qt toolkit"
+SLOT="4"
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS=""
+else
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+fi
+IUSE="connman networkmanager"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}[aqua=,debug=]
+ connman? ( ~dev-qt/qtdbus-${PV}[aqua=,debug=] )
+ networkmanager? ( ~dev-qt/qtdbus-${PV}[aqua=,debug=] )
+"
+RDEPEND="${DEPEND}
+ connman? ( net-misc/connman )
+ networkmanager? ( net-misc/networkmanager )
+"
+
+pkg_setup() {
+ QT4_EXTRACT_DIRECTORIES="
+ include/QtCore
+ include/QtDBus
+ include/QtNetwork
+ src/corelib
+ src/dbus
+ src/network
+ src/plugins/bearer
+ src/plugins/qpluginbase.pri"
+
+ QT4_TARGET_DIRECTORIES="
+ src/plugins/bearer/generic
+ $(use connman && echo src/plugins/bearer/connman)
+ $(use networkmanager && echo src/plugins/bearer/networkmanager)"
+
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf+="
+ $(use connman || use networkmanager || echo -no-dbus)
+ -no-accessibility -no-xmlpatterns -no-multimedia -no-audio-backend -no-phonon
+ -no-phonon-backend -no-svg -no-webkit -no-script -no-scripttools -no-declarative
+ -system-zlib -no-gif -no-libtiff -no-libpng -no-libmng -no-libjpeg
+ -no-cups -no-gtkstyle -no-nas-sound -no-opengl
+ -no-sm -no-xshape -no-xvideo -no-xsync -no-xinerama -no-xcursor -no-xfixes
+ -no-xrandr -no-xrender -no-mitshm -no-fontconfig -no-freetype -no-xinput -no-xkb"
+
+ qt4-build_src_configure
+}
diff --git a/dev-qt/qtbearer/qtbearer-4.8.6-r1.ebuild b/dev-qt/qtbearer/qtbearer-4.8.6-r1.ebuild
new file mode 100644
index 00000000000..215e9ca01bb
--- /dev/null
+++ b/dev-qt/qtbearer/qtbearer-4.8.6-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qt4-build-multilib
+
+DESCRIPTION="The network bearer plugins for the Qt toolkit"
+
+if [[ ${QT4_BUILD_TYPE} == live ]]; then
+ KEYWORDS="alpha arm hppa ia64 ppc ppc64"
+else
+ KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-fbsd ~x86-fbsd"
+fi
+
+IUSE="connman networkmanager"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
+ connman? ( ~dev-qt/qtdbus-${PV}[aqua=,debug=,${MULTILIB_USEDEP}] )
+ networkmanager? ( ~dev-qt/qtdbus-${PV}[aqua=,debug=,${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}
+ connman? ( net-misc/connman )
+ networkmanager? ( net-misc/networkmanager )
+"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/plugins/bearer/generic
+ $(use connman && echo src/plugins/bearer/connman)
+ $(use networkmanager && echo src/plugins/bearer/networkmanager)"
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(use connman || use networkmanager || echo -no-dbus)
+ -no-accessibility -no-xmlpatterns -no-multimedia -no-audio-backend -no-phonon
+ -no-phonon-backend -no-svg -no-webkit -no-script -no-scripttools -no-declarative
+ -system-zlib -no-gif -no-libtiff -no-libpng -no-libmng -no-libjpeg
+ -no-cups -no-gtkstyle -no-nas-sound -no-opengl
+ -no-sm -no-xshape -no-xvideo -no-xsync -no-xinerama -no-xcursor -no-xfixes
+ -no-xrandr -no-xrender -no-mitshm -no-fontconfig -no-freetype -no-xinput -no-xkb
+ )
+ qt4_multilib_src_configure
+}
diff --git a/dev-qt/qtbearer/qtbearer-4.8.7.ebuild b/dev-qt/qtbearer/qtbearer-4.8.7.ebuild
new file mode 100644
index 00000000000..1acda2e3a05
--- /dev/null
+++ b/dev-qt/qtbearer/qtbearer-4.8.7.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit qt4-build-multilib
+
+DESCRIPTION="The network bearer plugins for the Qt toolkit"
+
+if [[ ${QT4_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+fi
+
+IUSE="connman networkmanager"
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}[aqua=,debug=,${MULTILIB_USEDEP}]
+ connman? ( ~dev-qt/qtdbus-${PV}[aqua=,debug=,${MULTILIB_USEDEP}] )
+ networkmanager? ( ~dev-qt/qtdbus-${PV}[aqua=,debug=,${MULTILIB_USEDEP}] )
+"
+RDEPEND="${DEPEND}
+ connman? ( net-misc/connman )
+ networkmanager? ( net-misc/networkmanager )
+"
+
+pkg_setup() {
+ QT4_TARGET_DIRECTORIES="
+ src/plugins/bearer/generic
+ $(use connman && echo src/plugins/bearer/connman)
+ $(use networkmanager && echo src/plugins/bearer/networkmanager)"
+}
+
+multilib_src_configure() {
+ local myconf=(
+ $(use connman || use networkmanager || echo -no-dbus)
+ -no-accessibility -no-xmlpatterns -no-multimedia -no-audio-backend -no-phonon
+ -no-phonon-backend -no-svg -no-webkit -no-script -no-scripttools -no-declarative
+ -system-zlib -no-gif -no-libtiff -no-libpng -no-libmng -no-libjpeg
+ -no-cups -no-gtkstyle -no-nas-sound -no-opengl
+ -no-sm -no-xshape -no-xvideo -no-xsync -no-xinerama -no-xcursor -no-xfixes
+ -no-xrandr -no-xrender -no-mitshm -no-fontconfig -no-freetype -no-xinput -no-xkb
+ )
+ qt4_multilib_src_configure
+}