summaryrefslogtreecommitdiff
path: root/dev-qt/qthelp/qthelp-5.12.3.ebuild
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-04-20 22:43:44 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-04-21 13:30:57 +0200
commitf9795d7913848b507acc9b7385cfd19725b71445 (patch)
tree76b6dc32684e0cf3a04130fe1f6d1a985459beac /dev-qt/qthelp/qthelp-5.12.3.ebuild
parent34683d463f8f9d6f67cae43b509098ed9f7b33e5 (diff)
downloadgentoo-f9795d7913848b507acc9b7385cfd19725b71445.tar.gz
gentoo-f9795d7913848b507acc9b7385cfd19725b71445.tar.xz
dev-qt: Add Qt 5.12.3
Package-Manager: Portage-2.3.64, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qthelp/qthelp-5.12.3.ebuild')
-rw-r--r--dev-qt/qthelp/qthelp-5.12.3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-qt/qthelp/qthelp-5.12.3.ebuild b/dev-qt/qthelp/qthelp-5.12.3.ebuild
new file mode 100644
index 00000000000..943173a184c
--- /dev/null
+++ b/dev-qt/qthelp/qthelp-5.12.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+QT5_MODULE="qttools"
+inherit qt5-build
+
+DESCRIPTION="Qt5 module for integrating online documentation into applications"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtgui-${PV}
+ ~dev-qt/qtnetwork-${PV}
+ ~dev-qt/qtsql-${PV}[sqlite]
+ ~dev-qt/qtwidgets-${PV}
+"
+RDEPEND="${DEPEND}"
+
+QT5_TARGET_SUBDIRS=(
+ src/assistant/help
+ src/assistant/qcollectiongenerator
+ src/assistant/qhelpgenerator
+)