summaryrefslogtreecommitdiff
path: root/dev-qt/qtscxml
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-18 23:14:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-18 23:39:12 +0200
commit59f65abccf9c18ffca2223466dbcac028aba3ca1 (patch)
treea24a4de1b6e92057845509129b7d9d6aefb6f0bf /dev-qt/qtscxml
parenta849586cc781cbcea16e81b3616cbfc91c248876 (diff)
downloadgentoo-59f65abccf9c18ffca2223466dbcac028aba3ca1.tar.gz
gentoo-59f65abccf9c18ffca2223466dbcac028aba3ca1.tar.xz
dev-qt: Add Qt 5.11.2
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-qt/qtscxml')
-rw-r--r--dev-qt/qtscxml/Manifest1
-rw-r--r--dev-qt/qtscxml/qtscxml-5.11.2.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-qt/qtscxml/Manifest b/dev-qt/qtscxml/Manifest
index 8fa3c2f04c2..e9fcc6dddb2 100644
--- a/dev-qt/qtscxml/Manifest
+++ b/dev-qt/qtscxml/Manifest
@@ -1,2 +1,3 @@
DIST qtscxml-everywhere-src-5.11.1.tar.xz 436148 BLAKE2B d26d8e54bc89685110168043ec876fa8bb34c0c23ed31c625d26f71e82283716ed70e3fd71ad02233bd69546ace02cb87549ef3270e3bd43c0758db480db3639 SHA512 d64dba323b009525078e999e0972fd09a16bb806980411ce7cc452aee0951632ee440f71c2b5124cfd6ed5020aa869d8490017aaba374a8d4b83f43c1f0b0689
+DIST qtscxml-everywhere-src-5.11.2.tar.xz 430496 BLAKE2B 7c6ec84440fa2a0c54de24587d17af9cb2b09b7c11056da32c091954c87f21b448f512aa131d9051377a9052f7e8c09f00e259b071a0879ccf244bd3f623c114 SHA512 4175d02224654a6a6b220f52937a22093be8b06e737f5575d4227b9038cb7c227f37eb17b7bb6878c16a34eae342c06e33cb2c356a389137e9f7d15886aa30ab
DIST qtscxml-opensource-src-5.9.6.tar.xz 414120 BLAKE2B 90458c151e42308d660556871ab4ce4972a2d620d9785d2f39b2c913d0fa35522be5fcc459838f42c93b6ad6d76a0022b85cd3cf367fcdb77004f199091e0d4d SHA512 d649a43b5d9b753c431120972be93a190583315045d724ea5149ba93a73aa65724eef8a8b0d33f48a543418e045961e91af1d068774a923469f871ed3a97d4fe
diff --git a/dev-qt/qtscxml/qtscxml-5.11.2.ebuild b/dev-qt/qtscxml/qtscxml-5.11.2.ebuild
new file mode 100644
index 00000000000..3a0e878ad0e
--- /dev/null
+++ b/dev-qt/qtscxml/qtscxml-5.11.2.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qt5-build
+
+DESCRIPTION="State Chart XML (SCXML) support library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ KEYWORDS="~amd64 ~x86"
+fi
+
+IUSE=""
+
+DEPEND="
+ ~dev-qt/qtcore-${PV}
+ ~dev-qt/qtdeclarative-${PV}
+"
+RDEPEND="${DEPEND}"