summaryrefslogtreecommitdiff
path: root/dev-ros/dynamic_reconfigure
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 17:31:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 17:52:46 +0200
commit4e0d3c866fc15b0c1e66ea99d5ee4d59cc7b3360 (patch)
treeada7ea3d353149ff2751688493e229b663d8b235 /dev-ros/dynamic_reconfigure
parentce781d28721191aec3c680423bf51b44b7de2622 (diff)
downloadgentoo-4e0d3c866fc15b0c1e66ea99d5ee4d59cc7b3360.tar.gz
gentoo-4e0d3c866fc15b0c1e66ea99d5ee4d59cc7b3360.tar.xz
dev-ros/dynamic_reconfigure: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/dynamic_reconfigure')
-rw-r--r--dev-ros/dynamic_reconfigure/Manifest1
-rw-r--r--dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.39.ebuild24
-rw-r--r--dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild24
-rw-r--r--dev-ros/dynamic_reconfigure/metadata.xml5
4 files changed, 54 insertions, 0 deletions
diff --git a/dev-ros/dynamic_reconfigure/Manifest b/dev-ros/dynamic_reconfigure/Manifest
new file mode 100644
index 00000000000..239336f383f
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/Manifest
@@ -0,0 +1 @@
+DIST dynamic_reconfigure-1.5.39.tar.gz 34301 SHA256 6884a5f6bcd660598529b6e68f318406d2897a289cbc41d81c4d912132c71856 SHA512 0d069b2762d785494dfb4297bff550d3b113be26485cc754884ad3de687129b5fc1a74a6e30ff35348ec57d5e916b1cc76033d56dc540fd7f9e6eaae262c6ca2 WHIRLPOOL 4e29c8ba66729405281835f5636681c2104e88b80840bc68c2c2cf81d1775364e3906bcb122932545638cfa8cd9e6d53efd834bff25c5fad79bb49667887f1b4
diff --git a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.39.ebuild b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.39.ebuild
new file mode 100644
index 00000000000..7f15404cec5
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-1.5.39.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a means to change node parameters at any time without having to restart the node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild
new file mode 100644
index 00000000000..7f15404cec5
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/dynamic_reconfigure-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/dynamic_reconfigure"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a means to change node parameters at any time without having to restart the node"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/dynamic_reconfigure/metadata.xml b/dev-ros/dynamic_reconfigure/metadata.xml
new file mode 100644
index 00000000000..c42ea5b15cf
--- /dev/null
+++ b/dev-ros/dynamic_reconfigure/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>