summaryrefslogtreecommitdiff
path: root/dev-ros/filters/filters-1.8.1.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-26 19:32:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-26 19:32:53 +0200
commit5f4ca5418653389177cdc0cd9e682677b0c120bb (patch)
treefeb7cabadf5bd6e1b43a2a83e0c24c2f0535adac /dev-ros/filters/filters-1.8.1.ebuild
parent8e5ecfb05b32c9f110b389a1f9bc1b00e41b379a (diff)
downloadgentoo-5f4ca5418653389177cdc0cd9e682677b0c120bb.tar.gz
gentoo-5f4ca5418653389177cdc0cd9e682677b0c120bb.tar.xz
dev-ros/filters: bump to 1.8.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ros/filters/filters-1.8.1.ebuild')
-rw-r--r--dev-ros/filters/filters-1.8.1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/filters/filters-1.8.1.ebuild b/dev-ros/filters/filters-1.8.1.ebuild
new file mode 100644
index 00000000000..a5238e0d114
--- /dev/null
+++ b/dev-ros/filters/filters-1.8.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/filters"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Standardized interface for processing data as a sequence of filters"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-ros/roscpp
+ dev-libs/boost:=[threads]
+ dev-ros/pluginlib"
+DEPEND="${RDEPEND}
+ test? ( dev-ros/rostest dev-cpp/gtest )"