summaryrefslogtreecommitdiff
path: root/dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-16 14:32:23 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-16 14:36:44 +0100
commit39c37f1ae00318fc1b4fab06ec6e55b15bc0e45b (patch)
treec7cbafc36bd0bfd150eabef827821b535286b516 /dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild
parent7839d776209ff995d31dd98cdad8a50b57df4b86 (diff)
downloadgentoo-39c37f1ae00318fc1b4fab06ec6e55b15bc0e45b.tar.gz
gentoo-39c37f1ae00318fc1b4fab06ec6e55b15bc0e45b.tar.xz
dev-ros/gazebo_plugins: bump to 2.7.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild')
-rw-r--r--dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild b/dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild
new file mode 100644
index 00000000000..ef6837eae89
--- /dev/null
+++ b/dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-simulation/gazebo_ros_pkgs"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+CATKIN_HAS_MESSAGES=yes
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components"
+LICENSE="BSD Apache-2.0"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/gazebo_dev
+ dev-ros/gazebo_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/roscpp
+ dev-ros/rospy
+ dev-ros/nodelet
+ dev-ros/angles
+ dev-ros/std_srvs
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/urdf
+ dev-ros/tf
+ dev-ros/tf2_ros
+ dev-ros/dynamic_reconfigure[${PYTHON_USEDEP}]
+ dev-ros/driver_base[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/trajectory_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/pcl_conversions
+ dev-ros/image_transport
+ dev-ros/rosconsole
+ dev-ros/cv_bridge
+ media-libs/opencv:=
+ dev-ros/polled_camera
+ dev-ros/diagnostic_updater
+ dev-ros/camera_info_manager
+ dev-ros/moveit_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-libs/libxml2
+ >=sci-electronics/gazebo-7:=
+ dev-libs/protobuf:=
+ dev-games/ogre
+ sci-libs/pcl
+ dev-libs/boost:=
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"