summaryrefslogtreecommitdiff
path: root/dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-01-28 13:51:54 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-01-28 13:54:34 +0100
commit4991b04dd4102116b405a9df7e8007fccd271102 (patch)
tree531398f9be092d75ede40d22c55530a26e3115c1 /dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild
parent431d9497f100fe8f20e85c377ad6d71de9ee53d3 (diff)
downloadgentoo-4991b04dd4102116b405a9df7e8007fccd271102.tar.gz
gentoo-4991b04dd4102116b405a9df7e8007fccd271102.tar.xz
dev-ros/gazebo_plugins: backport upstream fixes to build with gazebo 9
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild')
-rw-r--r--dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild b/dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild
index ef6837eae89..76ce67a6f0b 100644
--- a/dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild
+++ b/dev-ros/gazebo_plugins/gazebo_plugins-2.7.3.ebuild
@@ -8,7 +8,7 @@ PYTHON_COMPAT=( python{2_7,3_4,3_5} )
CATKIN_HAS_MESSAGES=yes
ROS_SUBDIR=${PN}
-inherit ros-catkin
+inherit ros-catkin eutils
DESCRIPTION="Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components"
LICENSE="BSD Apache-2.0"
@@ -51,3 +51,12 @@ RDEPEND="
dev-ros/roslib[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}"
+SRC_URI="${SRC_URI}
+ mirror://gentoo/gazebo-ros-2.7.3-patches-1.tar.bz2"
+
+src_prepare() {
+ pushd "${WORKDIR}/gazebo_ros_pkgs-${PV}" || die
+ EPATCH_FORCE=yes EPATCH_SUFFIX="patch" epatch "${WORKDIR}/patches"
+ popd || die
+ ros-catkin_src_prepare
+}