summaryrefslogtreecommitdiff
path: root/dev-ros/hector_mapping
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-28 14:56:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-28 14:56:27 +0200
commit5aac6f55d35458f0e2effe16d81b2e294944b30d (patch)
tree29578bc058c2019202b80345513f1a0dbe9cd9a9 /dev-ros/hector_mapping
parent00bf347935fa8bf8b1beeb1ee6a8f3aa11d1f805 (diff)
downloadgentoo-5aac6f55d35458f0e2effe16d81b2e294944b30d.tar.gz
gentoo-5aac6f55d35458f0e2effe16d81b2e294944b30d.tar.xz
dev-ros/hector_mapping: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/hector_mapping')
-rw-r--r--dev-ros/hector_mapping/Manifest1
-rw-r--r--dev-ros/hector_mapping/hector_mapping-0.3.3.ebuild29
-rw-r--r--dev-ros/hector_mapping/hector_mapping-9999.ebuild29
-rw-r--r--dev-ros/hector_mapping/metadata.xml5
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ros/hector_mapping/Manifest b/dev-ros/hector_mapping/Manifest
new file mode 100644
index 00000000000..8dc36f58a07
--- /dev/null
+++ b/dev-ros/hector_mapping/Manifest
@@ -0,0 +1 @@
+DIST hector_slam-0.3.3.tar.gz 64368 SHA256 e3da461e7e4020218ae3d26f2eb6e135d1ac486bb0dab52f60e9d2349c637e5c SHA512 755a639b865d897281f01e28ca8dcdf943d953422f38ba73ed7e982c22c178cb5becbb9d2962420136cad0927f5c412ce896fc9b1995b58d7163fb35a82c62c0 WHIRLPOOL 4813768350cb232d4171a2f1335472e07ddb526b8846f56f3820a2dd4c51673d3c26866554e1a5b3e097530265efd104bd2a5eeda7c25639af991b4696971d4d
diff --git a/dev-ros/hector_mapping/hector_mapping-0.3.3.ebuild b/dev-ros/hector_mapping/hector_mapping-0.3.3.ebuild
new file mode 100644
index 00000000000..c25585b6376
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-0.3.3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM approach that can be used without odometry and on platforms that exhibit roll/pitch motion"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
diff --git a/dev-ros/hector_mapping/hector_mapping-9999.ebuild b/dev-ros/hector_mapping/hector_mapping-9999.ebuild
new file mode 100644
index 00000000000..c25585b6376
--- /dev/null
+++ b/dev-ros/hector_mapping/hector_mapping-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/tu-darmstadt-ros-pkg/hector_slam"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/nav_msgs dev-ros/visualization_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="SLAM approach that can be used without odometry and on platforms that exhibit roll/pitch motion"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/message_filters
+ dev-ros/laser_geometry
+ dev-ros/tf_conversions
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ dev-cpp/eigen:3"
diff --git a/dev-ros/hector_mapping/metadata.xml b/dev-ros/hector_mapping/metadata.xml
new file mode 100644
index 00000000000..c42ea5b15cf
--- /dev/null
+++ b/dev-ros/hector_mapping/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>