summaryrefslogtreecommitdiff
path: root/dev-ros/hector_pose_estimation_core
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-10-07 12:48:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-10-07 12:56:03 +0200
commit9a3e69ba04e21a6ab4446df02557bdd85f250358 (patch)
tree8c0d202840e1ab8b498b294f348205e82f9e8c6d /dev-ros/hector_pose_estimation_core
parentbeab7424bc8e0065f70c093e53e48b0b450bdf17 (diff)
downloadgentoo-9a3e69ba04e21a6ab4446df02557bdd85f250358.tar.gz
gentoo-9a3e69ba04e21a6ab4446df02557bdd85f250358.tar.xz
dev-ros/hector_pose_estimation_core: add missing include in public header and dep on boost
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/hector_pose_estimation_core')
-rw-r--r--dev-ros/hector_pose_estimation_core/files/includes.patch12
-rw-r--r--dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild (renamed from dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0.ebuild)2
-rw-r--r--dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild3
3 files changed, 16 insertions, 1 deletions
diff --git a/dev-ros/hector_pose_estimation_core/files/includes.patch b/dev-ros/hector_pose_estimation_core/files/includes.patch
new file mode 100644
index 00000000000..0188d027ed9
--- /dev/null
+++ b/dev-ros/hector_pose_estimation_core/files/includes.patch
@@ -0,0 +1,12 @@
+Index: hector_localization-0.3.0/hector_pose_estimation_core/include/hector_pose_estimation/state.h
+===================================================================
+--- hector_localization-0.3.0.orig/hector_pose_estimation_core/include/hector_pose_estimation/state.h
++++ hector_localization-0.3.0/hector_pose_estimation_core/include/hector_pose_estimation/state.h
+@@ -29,6 +29,7 @@
+ #ifndef HECTOR_POSE_ESTIMATION_STATE_H
+ #define HECTOR_POSE_ESTIMATION_STATE_H
+
++#include <vector>
+ #include <hector_pose_estimation/types.h>
+
+ #include <boost/function.hpp>
diff --git a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0.ebuild b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild
index 209d2fc442d..3fce19f6460 100644
--- a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0.ebuild
+++ b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-0.3.0-r1.ebuild
@@ -23,6 +23,8 @@ RDEPEND="
dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf
+ dev-libs/boost:=
"
DEPEND="${RDEPEND}
dev-cpp/eigen:3"
+PATCHES=( "${FILESDIR}/includes.patch" )
diff --git a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild
index 64f702c77b2..86071577fc9 100644
--- a/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild
+++ b/dev-ros/hector_pose_estimation_core/hector_pose_estimation_core-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -23,6 +23,7 @@ RDEPEND="
dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/geographic_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/tf
+ dev-libs/boost:=
"
DEPEND="${RDEPEND}
dev-cpp/eigen:3"