summaryrefslogtreecommitdiff
path: root/dev-ros/image_proc/image_proc-1.12.19.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-26 11:29:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-26 12:03:54 +0200
commitae16adb6fd2c565648ee8edf0a22aea6a9676925 (patch)
treeac6e8c18502751f82d6895f9dcf661a61fef7109 /dev-ros/image_proc/image_proc-1.12.19.ebuild
parent72aff0e36323033ddb0ee8390d3d03e711fd7eac (diff)
downloadgentoo-ae16adb6fd2c565648ee8edf0a22aea6a9676925.tar.gz
gentoo-ae16adb6fd2c565648ee8edf0a22aea6a9676925.tar.xz
dev-ros/image_proc: Bump to 1.12.19.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/image_proc/image_proc-1.12.19.ebuild')
-rw-r--r--dev-ros/image_proc/image_proc-1.12.19.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ros/image_proc/image_proc-1.12.19.ebuild b/dev-ros/image_proc/image_proc-1.12.19.ebuild
new file mode 100644
index 00000000000..08dd3217ec2
--- /dev/null
+++ b/dev-ros/image_proc/image_proc-1.12.19.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Single image rectification and color processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ media-libs/opencv
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"