summaryrefslogtreecommitdiff
path: root/dev-ros/image_proc
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-01-19 12:40:12 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-01-19 13:03:03 +0100
commit74197609b3a2e44b5efce9dec732dc0d45ddbbf0 (patch)
treeb6cbf3243c92c8b95c110fc3f501c317b0c0c4e8 /dev-ros/image_proc
parent9ab6b509aae1ee45b6361c8ed7af5b8ee77aa4dc (diff)
downloadgentoo-74197609b3a2e44b5efce9dec732dc0d45ddbbf0.tar.gz
gentoo-74197609b3a2e44b5efce9dec732dc0d45ddbbf0.tar.xz
dev-ros/image_proc: Bump to 1.12.15.
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/image_proc')
-rw-r--r--dev-ros/image_proc/Manifest1
-rw-r--r--dev-ros/image_proc/image_proc-1.12.15.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/image_proc/Manifest b/dev-ros/image_proc/Manifest
index 0cc1356d6b6..cf8b7d53eb7 100644
--- a/dev-ros/image_proc/Manifest
+++ b/dev-ros/image_proc/Manifest
@@ -1 +1,2 @@
DIST image_pipeline-1.12.14.tar.gz 118296 SHA256 8e3b756932a821b4387b7f86ca9fc5233ebb2a13541b220b866e42ea6f92b17f SHA512 724b6d20edab1436c51a05f4399b852cabab74c5e04dea97f53a256fb512b4dbfc97fd6e7d74d41bfd7d92fe183aa86a993a39b8687c27dc7b7f85d1a1c81b94 WHIRLPOOL 394343ddf299f6c7e26c0a2f45e49edc2c4047a0ccd15885a998fa902bb7373fa44181f06adc222483a285f32df800e0b268485cb2fd98e54956929056868d5d
+DIST image_pipeline-1.12.15.tar.gz 122012 SHA256 d9660a5929b69b7801b3a05e092c7a4a5543d45084c9198fdaa9c8a0210db76c SHA512 184805f99020332ad74899ec47abc56144aceef8d4eabf877a4dc85f30befdc78b209407e1be624ba151be3a71be1fafdbd87c771137bee7c080c24935f6c6fa WHIRLPOOL d9ceff4b34767e33fe8eae49076fae133dd8146c2b09fb3ce42c0c902c6d95a06cb990e5f543dfb0215a18b0592193d65c782a45301c18e4f8a34fb35e509449
diff --git a/dev-ros/image_proc/image_proc-1.12.15.ebuild b/dev-ros/image_proc/image_proc-1.12.15.ebuild
new file mode 100644
index 00000000000..fc4695ace62
--- /dev/null
+++ b/dev-ros/image_proc/image_proc-1.12.15.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Single image rectification and color processing"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/image_geometry
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ media-libs/opencv
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}"