summaryrefslogtreecommitdiff
path: root/dev-ros/image_publisher
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-26 12:00:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-26 12:03:54 +0200
commit6f4113208ce9126416cde7fb59b8556570558948 (patch)
tree5066239856524e6c7b3db6afa29b5eaabdd98dee /dev-ros/image_publisher
parent106aea1800be4e575fd7e7840d5de468cb6bf3f9 (diff)
downloadgentoo-6f4113208ce9126416cde7fb59b8556570558948.tar.gz
gentoo-6f4113208ce9126416cde7fb59b8556570558948.tar.xz
dev-ros/image_publisher: initial import; ebuild by me
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ros/image_publisher')
-rw-r--r--dev-ros/image_publisher/Manifest1
-rw-r--r--dev-ros/image_publisher/image_publisher-1.12.19.ebuild27
-rw-r--r--dev-ros/image_publisher/image_publisher-9999.ebuild27
-rw-r--r--dev-ros/image_publisher/metadata.xml11
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-ros/image_publisher/Manifest b/dev-ros/image_publisher/Manifest
new file mode 100644
index 00000000000..202746fbd20
--- /dev/null
+++ b/dev-ros/image_publisher/Manifest
@@ -0,0 +1 @@
+DIST image_pipeline-1.12.19.tar.gz 130635 SHA256 fc3073428fc930523efd6ed4a86d838ab0f0ff04a312eb4188c72a854d300e97 SHA512 f0677e4a811622ffc19792af828f4766408b6a051d271950a8a096d064b043dae1457b2a6f2d59fe5c2971795db04e7abf5e0878ead1428a4da19033693829ba WHIRLPOOL ecb1cdcc07109d3781bb82e88c0fe7e91754b2dfac0bfc7f5d053e6df9ce78b95b4131a9b65715fbce1b44b0acab6f833bd9c0d4f2fb68718fee4f4bfd586c63
diff --git a/dev-ros/image_publisher/image_publisher-1.12.19.ebuild b/dev-ros/image_publisher/image_publisher-1.12.19.ebuild
new file mode 100644
index 00000000000..c7d3a6523f2
--- /dev/null
+++ b/dev-ros/image_publisher/image_publisher-1.12.19.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Publish an image stream from single image file or avi file."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/camera_info_manager
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/image_publisher/image_publisher-9999.ebuild b/dev-ros/image_publisher/image_publisher-9999.ebuild
new file mode 100644
index 00000000000..c7d3a6523f2
--- /dev/null
+++ b/dev-ros/image_publisher/image_publisher-9999.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/image_pipeline"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Publish an image stream from single image file or avi file."
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/cv_bridge
+ dev-ros/dynamic_reconfigure
+ dev-ros/camera_info_manager
+ dev-ros/image_transport
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/image_publisher/metadata.xml b/dev-ros/image_publisher/metadata.xml
new file mode 100644
index 00000000000..7536ca01cdf
--- /dev/null
+++ b/dev-ros/image_publisher/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros-perception/image_pipeline</remote-id>
+ </upstream>
+</pkgmetadata>