summaryrefslogtreecommitdiff
path: root/dev-ros/interval_intersection/interval_intersection-0.10.13.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 16:00:38 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 16:34:21 +0200
commit95a6f201a0413939bcb08d3410f126a580027932 (patch)
tree907ec86318d0f974e709002f017c654803e61711 /dev-ros/interval_intersection/interval_intersection-0.10.13.ebuild
parent6cbb9692eb7cddf6462f76a2146049db8fec4ef5 (diff)
downloadgentoo-95a6f201a0413939bcb08d3410f126a580027932.tar.gz
gentoo-95a6f201a0413939bcb08d3410f126a580027932.tar.xz
dev-ros/interval_intersection: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/interval_intersection/interval_intersection-0.10.13.ebuild')
-rw-r--r--dev-ros/interval_intersection/interval_intersection-0.10.13.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/interval_intersection/interval_intersection-0.10.13.ebuild b/dev-ros/interval_intersection/interval_intersection-0.10.13.ebuild
new file mode 100644
index 00000000000..273edb7e86b
--- /dev/null
+++ b/dev-ros/interval_intersection/interval_intersection-0.10.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/actionlib
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"