summaryrefslogtreecommitdiff
path: root/dev-ros/interval_intersection
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-19 14:55:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-19 15:07:21 +0200
commitdfae586646c96ab4b82df87e9701cf87793112af (patch)
tree58a544f4b28f6a644fa8872004196b85ca846a5f /dev-ros/interval_intersection
parent877d246ac5e96d5c18691e9aa6af970d4bb30681 (diff)
downloadgentoo-dfae586646c96ab4b82df87e9701cf87793112af.tar.gz
gentoo-dfae586646c96ab4b82df87e9701cf87793112af.tar.xz
dev-ros/interval_intersection: Bump to 0.10.14.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/interval_intersection')
-rw-r--r--dev-ros/interval_intersection/Manifest1
-rw-r--r--dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/interval_intersection/Manifest b/dev-ros/interval_intersection/Manifest
index 38907048959..93fa7e06808 100644
--- a/dev-ros/interval_intersection/Manifest
+++ b/dev-ros/interval_intersection/Manifest
@@ -1 +1,2 @@
DIST calibration-0.10.13.tar.gz 112305 SHA256 935755f9428e6b998d1a9ce10fcf11f3c119953ebe0b65eda855804ec8b8aea8 SHA512 95b5ea28428ea9726b6b1a8f24cd4c7cb84992e680761357c1a13dd92c362149a0a6104f6a44dbefad503db1a9c7a53135d9756b1ceea3a739b1baa14f9474eb WHIRLPOOL 94423d70268b053daee1da1b324582d2f8316c6feaa5c9291715b1861520cb2e67654daaa2156e8d15cd59ecb566bdd3cb76d42c7202b85680888bac3532002c
+DIST calibration-0.10.14.tar.gz 112475 SHA256 1e65e6d8f793e7a27d1975ec3c4b63bf5249c7ce859dd11187258560901d1c77 SHA512 5ef17cd21e04c134717859ecb12c4e7fc0086b044cf7d35d40bd43439a0f24e8ad41fe7b5fa37dcc8ec5e4abb2be8f64d86510706a3d97510cf1b92c2196ad40 WHIRLPOOL 5c1ea989d438198044933927acfd7eb8426c9f5f253710ac63117b2a20c526acfea568f4b7b4f1930a43024bbcf4033f0f04c9e48108dc7e1cc629fb9e3c127f
diff --git a/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild b/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild
new file mode 100644
index 00000000000..273edb7e86b
--- /dev/null
+++ b/dev-ros/interval_intersection/interval_intersection-0.10.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/geometry_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for calculating the intersection of interval messages coming in on several topics"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=[threads]
+ dev-ros/actionlib
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/roscpp_serialization
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"