summaryrefslogtreecommitdiff
path: root/dev-ros/mavros_extras/mavros_extras-0.16.4.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-12-15 10:10:27 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-12-15 10:10:27 +0100
commit02d135d220476b058fafe3ad05181d6a6b369555 (patch)
tree1607d17c49de8996c378edb2bdd06fc9fcd4d669 /dev-ros/mavros_extras/mavros_extras-0.16.4.ebuild
parente036b211fe6a77e7ef85a998a7fb81d6055274a1 (diff)
downloadgentoo-02d135d220476b058fafe3ad05181d6a6b369555.tar.gz
gentoo-02d135d220476b058fafe3ad05181d6a6b369555.tar.xz
dev-ros/mavros_extras: Bump to 0.16.4.
Package-Manager: portage-2.2.26 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/mavros_extras/mavros_extras-0.16.4.ebuild')
-rw-r--r--dev-ros/mavros_extras/mavros_extras-0.16.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ros/mavros_extras/mavros_extras-0.16.4.ebuild b/dev-ros/mavros_extras/mavros_extras-0.16.4.ebuild
new file mode 100644
index 00000000000..56228139855
--- /dev/null
+++ b/dev-ros/mavros_extras/mavros_extras-0.16.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/mavlink/mavros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Extra nodes and plugins for mavros"
+LICENSE="GPL-3 LGPL-3 BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/image_transport
+ dev-ros/cv_bridge
+ dev-ros/mavros
+ dev-ros/roscpp
+ dev-ros/mavros_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/urdf
+ dev-cpp/eigen:3
+"
+DEPEND="${RDEPEND}"