summaryrefslogtreecommitdiff
path: root/dev-ros/mk
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 13:42:55 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 13:42:55 +0200
commite55ffaa2027668a4050d62c45c798fdddced2e99 (patch)
tree25b13894ef6111e4e7ba2e8268aa09b3b7105182 /dev-ros/mk
parentfa486dc9439b42aba4aeb6bab6b0934d2cd96219 (diff)
downloadgentoo-e55ffaa2027668a4050d62c45c798fdddced2e99.tar.gz
gentoo-e55ffaa2027668a4050d62c45c798fdddced2e99.tar.xz
dev-ros/mk: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/mk')
-rw-r--r--dev-ros/mk/Manifest1
-rw-r--r--dev-ros/mk/metadata.xml5
-rw-r--r--dev-ros/mk/mk-1.12.3.ebuild19
-rw-r--r--dev-ros/mk/mk-9999.ebuild19
4 files changed, 44 insertions, 0 deletions
diff --git a/dev-ros/mk/Manifest b/dev-ros/mk/Manifest
new file mode 100644
index 00000000000..02c7ccc4a2a
--- /dev/null
+++ b/dev-ros/mk/Manifest
@@ -0,0 +1 @@
+DIST ros-1.12.3.tar.gz 162506 SHA256 49b9368e901d69f464b46c9ff0d12843d413fe20c4271225dbb75169bb82a47e SHA512 fe740f357959ed2cabcf0d902c7f1ebe6a7dedd11376ec76e5f47383b0b29b15127306255bea9adb3a48b2872a681a10302f9b0c4da4625c31bcc78522b66d7c WHIRLPOOL d57a877f7b7dc2a6613d3ea07b59e740e25bfffbcec51fa4ce826ccdc9f95dd9aed121736f46338068f9cf06b52a6abc8462ce663bbd4519e7d93f16422995f5
diff --git a/dev-ros/mk/metadata.xml b/dev-ros/mk/metadata.xml
new file mode 100644
index 00000000000..c42ea5b15cf
--- /dev/null
+++ b/dev-ros/mk/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/mk/mk-1.12.3.ebuild b/dev-ros/mk/mk-1.12.3.ebuild
new file mode 100644
index 00000000000..fe1f6e99942
--- /dev/null
+++ b/dev-ros/mk/mk-1.12.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=core/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A collection of .mk include files for building ROS architectural elements"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/mk/mk-9999.ebuild b/dev-ros/mk/mk-9999.ebuild
new file mode 100644
index 00000000000..fe1f6e99942
--- /dev/null
+++ b/dev-ros/mk/mk-9999.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=core/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="A collection of .mk include files for building ROS architectural elements"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"