summaryrefslogtreecommitdiff
path: root/dev-ros/nav_core/nav_core-9999.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 12:36:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commit61b812216841a9ac06ce96e4a4deaf0aceff34a5 (patch)
treeebcf19ea0d2d625fd68e8d6d72f385a5f3754cb2 /dev-ros/nav_core/nav_core-9999.ebuild
parent5add068aaa33e3449d27b448578542f80587996b (diff)
downloadgentoo-61b812216841a9ac06ce96e4a4deaf0aceff34a5.tar.gz
gentoo-61b812216841a9ac06ce96e4a4deaf0aceff34a5.tar.xz
dev-ros/nav_core: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/nav_core/nav_core-9999.ebuild')
-rw-r--r--dev-ros/nav_core/nav_core-9999.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/nav_core/nav_core-9999.ebuild b/dev-ros/nav_core/nav_core-9999.ebuild
new file mode 100644
index 00000000000..c73919561b3
--- /dev/null
+++ b/dev-ros/nav_core/nav_core-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Common interfaces for navigation specific robot actions"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+ dev-ros/costmap_2d
+"
+DEPEND="${RDEPEND}"