summaryrefslogtreecommitdiff
path: root/dev-ros/pcl_msgs
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 13:24:58 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 13:52:22 +0200
commitd9e320138308e37c697cac3667828740d1b84db0 (patch)
tree75fab8b5b26ebae560201bcb30e6557d7d9cf205 /dev-ros/pcl_msgs
parentf07498143bb9f122631be76c747342c696e9b79b (diff)
downloadgentoo-d9e320138308e37c697cac3667828740d1b84db0.tar.gz
gentoo-d9e320138308e37c697cac3667828740d1b84db0.tar.xz
dev-ros/pcl_msgs: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/pcl_msgs')
-rw-r--r--dev-ros/pcl_msgs/Manifest1
-rw-r--r--dev-ros/pcl_msgs/metadata.xml5
-rw-r--r--dev-ros/pcl_msgs/pcl_msgs-0.2.0.ebuild20
-rw-r--r--dev-ros/pcl_msgs/pcl_msgs-9999.ebuild20
4 files changed, 46 insertions, 0 deletions
diff --git a/dev-ros/pcl_msgs/Manifest b/dev-ros/pcl_msgs/Manifest
new file mode 100644
index 00000000000..c7ba58722b0
--- /dev/null
+++ b/dev-ros/pcl_msgs/Manifest
@@ -0,0 +1 @@
+DIST pcl_msgs-0.2.0.tar.gz 1596 SHA256 d02be421db01d22f8555f616b3658682ee60a885cc3dc37668fbc28454f562f8 SHA512 e132ad068683829d4f73b451584ce7e67a75b8ded9397b50c6bd92f5cb8a862303e766b5d3e0d7c1430e8241993166493167e2c3d2010a600dfbb66db0e87eae WHIRLPOOL 8119b92b3017b5581ba3f4b9d306a578e327246ddbeb5b695873ada10fdc216c7312c457a26a1464d015383bd24f2d7165fb1462dcbf1066f4ce53c164bcec02
diff --git a/dev-ros/pcl_msgs/metadata.xml b/dev-ros/pcl_msgs/metadata.xml
new file mode 100644
index 00000000000..c42ea5b15cf
--- /dev/null
+++ b/dev-ros/pcl_msgs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/pcl_msgs/pcl_msgs-0.2.0.ebuild b/dev-ros/pcl_msgs/pcl_msgs-0.2.0.ebuild
new file mode 100644
index 00000000000..f90c2f42859
--- /dev/null
+++ b/dev-ros/pcl_msgs/pcl_msgs-0.2.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros-perception/pcl_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="PCL (Point Cloud Library)-related ROS messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/pcl_msgs/pcl_msgs-9999.ebuild b/dev-ros/pcl_msgs/pcl_msgs-9999.ebuild
new file mode 100644
index 00000000000..f90c2f42859
--- /dev/null
+++ b/dev-ros/pcl_msgs/pcl_msgs-9999.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros-perception/pcl_msgs"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/sensor_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="PCL (Point Cloud Library)-related ROS messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"