summaryrefslogtreecommitdiff
path: root/dev-ros/pointcloud_to_laserscan
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 13:51:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 13:52:23 +0200
commit2b10395a920e4c62670615cfd4b51539412a2e6b (patch)
treeeedad5dbf793e6f9b7f1c323b9a4cb69bbbc1717 /dev-ros/pointcloud_to_laserscan
parent3127ad231f7ecb77d4fbbcbcaa334604179103de (diff)
downloadgentoo-2b10395a920e4c62670615cfd4b51539412a2e6b.tar.gz
gentoo-2b10395a920e4c62670615cfd4b51539412a2e6b.tar.xz
dev-ros/pointcloud_to_laserscan: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/pointcloud_to_laserscan')
-rw-r--r--dev-ros/pointcloud_to_laserscan/Manifest1
-rw-r--r--dev-ros/pointcloud_to_laserscan/metadata.xml5
-rw-r--r--dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.3.0.ebuild25
-rw-r--r--dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild25
4 files changed, 56 insertions, 0 deletions
diff --git a/dev-ros/pointcloud_to_laserscan/Manifest b/dev-ros/pointcloud_to_laserscan/Manifest
new file mode 100644
index 00000000000..3ba78e8fb06
--- /dev/null
+++ b/dev-ros/pointcloud_to_laserscan/Manifest
@@ -0,0 +1 @@
+DIST pointcloud_to_laserscan-1.3.0.tar.gz 6115 SHA256 704b79a179f415a71acb4c4c42793a49bd0a018ec6b1e2c71a3592decd8f4585 SHA512 a41b1c42048dde6ee73ca33f71e8e39354e4ebc0e91274eee590497d703c6ea9e0954e79d24cf828c3c1eac68377f894c728cff26b46a73f0d8cd3d7f6195c00 WHIRLPOOL edb45d94730c36c1fc617df43d52d24c15d23f05c4e9452a12d610578c175396dbe2129be51e00cf9191696284f1b7f3cfd4a6b670cf2adb5c2b87b230d93816
diff --git a/dev-ros/pointcloud_to_laserscan/metadata.xml b/dev-ros/pointcloud_to_laserscan/metadata.xml
new file mode 100644
index 00000000000..c42ea5b15cf
--- /dev/null
+++ b/dev-ros/pointcloud_to_laserscan/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.3.0.ebuild b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.3.0.ebuild
new file mode 100644
index 00000000000..2f960a53e0b
--- /dev/null
+++ b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-1.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/pointcloud_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a 3D Point Cloud into a 2D laser scan"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/tf2_sensor_msgs
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild
new file mode 100644
index 00000000000..2f960a53e0b
--- /dev/null
+++ b/dev-ros/pointcloud_to_laserscan/pointcloud_to_laserscan-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/pointcloud_to_laserscan"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Converts a 3D Point Cloud into a 2D laser scan"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_ros
+ dev-ros/tf2_sensor_msgs
+"
+DEPEND="${RDEPEND}"