summaryrefslogtreecommitdiff
path: root/dev-ros/qt_gui_app
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:08:06 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:12:08 +0200
commit0171f2627689bc308b315de85a2b554169d828b3 (patch)
tree9a6608b87712e916bb2f51463aba7d4ed8a5ea52 /dev-ros/qt_gui_app
parent2c435247e23d9ca4ca497af1145ce711cd60d3f2 (diff)
downloadgentoo-0171f2627689bc308b315de85a2b554169d828b3.tar.gz
gentoo-0171f2627689bc308b315de85a2b554169d828b3.tar.xz
dev-ros/qt_gui_app: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/qt_gui_app')
-rw-r--r--dev-ros/qt_gui_app/Manifest1
-rw-r--r--dev-ros/qt_gui_app/metadata.xml5
-rw-r--r--dev-ros/qt_gui_app/qt_gui_app-0.2.29.ebuild22
-rw-r--r--dev-ros/qt_gui_app/qt_gui_app-9999.ebuild22
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-ros/qt_gui_app/Manifest b/dev-ros/qt_gui_app/Manifest
new file mode 100644
index 00000000000..85ca418d4e9
--- /dev/null
+++ b/dev-ros/qt_gui_app/Manifest
@@ -0,0 +1 @@
+DIST qt_gui_core-0.2.29.tar.gz 85881 SHA256 7c51b4fd7e795e37e3f8a4b691a5e520466105fdddbc85e194c10c608fe7448c SHA512 958526a3bd76070e121d75a82c589894aef980870091cb853802fcb60328b54cbc95ee0c9eececa18e24608808cca2c722c5699b662c2a578f150995171d71db WHIRLPOOL f83328ce59fd9cd8db5a066f1a2a93bde54b28268891b18cf73b31d5584b0dc7f932350a39e729c97be3bc3b6780422dd2538321f29b0acd13d06387e0054975
diff --git a/dev-ros/qt_gui_app/metadata.xml b/dev-ros/qt_gui_app/metadata.xml
new file mode 100644
index 00000000000..c42ea5b15cf
--- /dev/null
+++ b/dev-ros/qt_gui_app/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/qt_gui_app/qt_gui_app-0.2.29.ebuild b/dev-ros/qt_gui_app/qt_gui_app-0.2.29.ebuild
new file mode 100644
index 00000000000..d0231cff11d
--- /dev/null
+++ b/dev-ros/qt_gui_app/qt_gui_app-0.2.29.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Main to start an instance of the integrated graphical user interface provided by qt_gui"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/qt_gui_app/qt_gui_app-9999.ebuild b/dev-ros/qt_gui_app/qt_gui_app-9999.ebuild
new file mode 100644
index 00000000000..d0231cff11d
--- /dev/null
+++ b/dev-ros/qt_gui_app/qt_gui_app-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Main to start an instance of the integrated graphical user interface provided by qt_gui"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"