summaryrefslogtreecommitdiff
path: root/dev-ros/roscreate/roscreate-1.12.5.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 11:25:21 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 13:25:34 +0200
commit89043bcc3c0f0db78e029d63fa407c60ec074368 (patch)
tree566680966e7b58bf879897aab464852811bfd526 /dev-ros/roscreate/roscreate-1.12.5.ebuild
parent6909fb61cf4717c1326a94d104f8c19998ec1eba (diff)
downloadgentoo-89043bcc3c0f0db78e029d63fa407c60ec074368.tar.gz
gentoo-89043bcc3c0f0db78e029d63fa407c60ec074368.tar.xz
dev-ros/roscreate: Bump to 1.12.5.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/roscreate/roscreate-1.12.5.ebuild')
-rw-r--r--dev-ros/roscreate/roscreate-1.12.5.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/roscreate/roscreate-1.12.5.ebuild b/dev-ros/roscreate/roscreate-1.12.5.ebuild
new file mode 100644
index 00000000000..ce475951356
--- /dev/null
+++ b/dev-ros/roscreate/roscreate-1.12.5.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Tool that assists in the creation of ROS filesystem resources"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"