summaryrefslogtreecommitdiff
path: root/dev-ros/rosgraph/rosgraph-1.11.16.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-14 12:04:24 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-14 12:04:24 +0100
commit0dbc968910d22ac91d64fabcd8b0e2a2143d520a (patch)
tree2b944b3313ade76e2d2c67f4a97bda686963c1fd /dev-ros/rosgraph/rosgraph-1.11.16.ebuild
parent9baba8b457874b75c7ce3bda9dae2453135a867c (diff)
downloadgentoo-0dbc968910d22ac91d64fabcd8b0e2a2143d520a.tar.gz
gentoo-0dbc968910d22ac91d64fabcd8b0e2a2143d520a.tar.xz
dev-ros/rosgraph: Bump to 1.11.16.
Package-Manager: portage-2.2.24 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosgraph/rosgraph-1.11.16.ebuild')
-rw-r--r--dev-ros/rosgraph/rosgraph-1.11.16.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/rosgraph-1.11.16.ebuild b/dev-ros/rosgraph/rosgraph-1.11.16.ebuild
new file mode 100644
index 00000000000..b4d40e484bf
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-1.11.16.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"