summaryrefslogtreecommitdiff
path: root/dev-ros/rosgraph/rosgraph-1.12.1.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-21 10:49:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-21 11:07:36 +0200
commitd2b7c8431e4206020a1f6924647b34d306aee0c2 (patch)
tree33c8a9034b17a77c228129b839e7ce0d524e5324 /dev-ros/rosgraph/rosgraph-1.12.1.ebuild
parent99402b5dd733ed79db096f4cdcb09468e00fbb31 (diff)
downloadgentoo-d2b7c8431e4206020a1f6924647b34d306aee0c2.tar.gz
gentoo-d2b7c8431e4206020a1f6924647b34d306aee0c2.tar.xz
dev-ros/rosgraph: Bump to 1.12.1.
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ros/rosgraph/rosgraph-1.12.1.ebuild')
-rw-r--r--dev-ros/rosgraph/rosgraph-1.12.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/rosgraph-1.12.1.ebuild b/dev-ros/rosgraph/rosgraph-1.12.1.ebuild
new file mode 100644
index 00000000000..b4d40e484bf
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-1.12.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] )"