summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_graph
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:20:18 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:20:18 +0200
commite4ae2ae93909deaa3cb2d71faa0eb07aa70aef06 (patch)
tree79877bdfe4cd1a54046d9f1422317cd88e1b5c47 /dev-ros/rqt_graph
parent231eb79831ba0c4b060f9e2577a3f587c2ec1f64 (diff)
downloadgentoo-e4ae2ae93909deaa3cb2d71faa0eb07aa70aef06.tar.gz
gentoo-e4ae2ae93909deaa3cb2d71faa0eb07aa70aef06.tar.xz
dev-ros/rqt_graph: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_graph')
-rw-r--r--dev-ros/rqt_graph/Manifest1
-rw-r--r--dev-ros/rqt_graph/metadata.xml5
-rw-r--r--dev-ros/rqt_graph/rqt_graph-0.3.12.ebuild32
-rw-r--r--dev-ros/rqt_graph/rqt_graph-9999.ebuild32
4 files changed, 70 insertions, 0 deletions
diff --git a/dev-ros/rqt_graph/Manifest b/dev-ros/rqt_graph/Manifest
new file mode 100644
index 00000000000..a503bd56f8f
--- /dev/null
+++ b/dev-ros/rqt_graph/Manifest
@@ -0,0 +1 @@
+DIST rqt_common_plugins-0.3.12.tar.gz 231733 SHA256 602ceea814b152865cd55c140565ec82d72277d9de75b869ce9fd3ac5a17b749 SHA512 567fb85324a85ef935379762026f7f3b5fbe491f61d947c273c1d138286acb919a2f458151b7137587bddbe028617934a75695a165fc7e7e6fd4b4cd87247b7d WHIRLPOOL d49809544f3de32129233c562f643afeed599b4f42688050aa433023188467243409ac048464eac05fc06f9a20c9d8992946dc68db0b01d7bcfde585a65fc42b
diff --git a/dev-ros/rqt_graph/metadata.xml b/dev-ros/rqt_graph/metadata.xml
new file mode 100644
index 00000000000..c42ea5b15cf
--- /dev/null
+++ b/dev-ros/rqt_graph/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/rqt_graph/rqt_graph-0.3.12.ebuild b/dev-ros/rqt_graph/rqt_graph-0.3.12.ebuild
new file mode 100644
index 00000000000..9cbcb40f8b5
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-0.3.12.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_graph/rqt_graph-9999.ebuild b/dev-ros/rqt_graph/rqt_graph-9999.ebuild
new file mode 100644
index 00000000000..9cbcb40f8b5
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"