summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_gui_py/rqt_gui_py-0.3.1.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-04-05 12:39:51 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-04-05 12:53:58 +0200
commit0e42366eb306562d6711604e1e3d8346bf1ad959 (patch)
tree790facd6c9a428b0dd5d916501dad0f3333f98c7 /dev-ros/rqt_gui_py/rqt_gui_py-0.3.1.ebuild
parent34b1ad80dbd1c796db71b055a390e3e82071a968 (diff)
downloadgentoo-0e42366eb306562d6711604e1e3d8346bf1ad959.tar.gz
gentoo-0e42366eb306562d6711604e1e3d8346bf1ad959.tar.xz
dev-ros/rqt_gui_py: Bump to 0.3.1.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_gui_py/rqt_gui_py-0.3.1.ebuild')
-rw-r--r--dev-ros/rqt_gui_py/rqt_gui_py-0.3.1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui_py/rqt_gui_py-0.3.1.ebuild b/dev-ros/rqt_gui_py/rqt_gui_py-0.3.1.ebuild
new file mode 100644
index 00000000000..ade4fca4a4f
--- /dev/null
+++ b/dev-ros/rqt_gui_py/rqt_gui_py-0.3.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ >=dev-ros/qt_gui-0.3.0[${PYTHON_USEDEP}]
+ >=dev-ros/rqt_gui-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"