summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:09:35 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:12:08 +0200
commit6fbaf2281d3aab7383adfd722de7f152c2be1b48 (patch)
tree3ea1979b5946b9d08f41e2acfbae31e0ec186a28 /dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild
parentc49601218f4ebd451d5d737725a58ac509d84020 (diff)
downloadgentoo-6fbaf2281d3aab7383adfd722de7f152c2be1b48.tar.gz
gentoo-6fbaf2281d3aab7383adfd722de7f152c2be1b48.tar.xz
dev-ros/rqt_gui_py: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild')
-rw-r--r--dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild b/dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild
new file mode 100644
index 00000000000..4c1e30c718a
--- /dev/null
+++ b/dev-ros/rqt_gui_py/rqt_gui_py-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/rqt"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Enables GUI plugins to use the Python client library for ROS"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"