summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_nav_view/rqt_nav_view-0.4.3.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-14 12:28:35 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-14 12:38:20 +0100
commit0d46c88f821768440f21667ba2f5d478a952b7a7 (patch)
treebc88342b1a8ae43e8a46067d7f45ba88ae6b9d04 /dev-ros/rqt_nav_view/rqt_nav_view-0.4.3.ebuild
parentab9d5e3b4bca43b53d0abcb7026d2ddc916ad37c (diff)
downloadgentoo-0d46c88f821768440f21667ba2f5d478a952b7a7.tar.gz
gentoo-0d46c88f821768440f21667ba2f5d478a952b7a7.tar.xz
dev-ros/rqt_nav_view: Bump to 0.4.3.
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_nav_view/rqt_nav_view-0.4.3.ebuild')
-rw-r--r--dev-ros/rqt_nav_view/rqt_nav_view-0.4.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rqt_nav_view/rqt_nav_view-0.4.3.ebuild b/dev-ros/rqt_nav_view/rqt_nav_view-0.4.3.ebuild
new file mode 100644
index 00000000000..d3c2bb79e11
--- /dev/null
+++ b/dev-ros/rqt_nav_view/rqt_nav_view-0.4.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_robot_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a gui for viewing navigation maps and paths"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/python_qt_binding[${PYTHON_USEDEP}]
+ dev-ros/qt_gui[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/tf[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"