summaryrefslogtreecommitdiff
path: root/dev-ros/rqt_plot
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-20 15:08:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-20 15:08:32 +0200
commit4fc1a4a28036742d249ee64905dbff0f3a7feb29 (patch)
tree99224ac3cca8975b0750c87681c6f4442752e947 /dev-ros/rqt_plot
parentdebcaadf81ede416614759265e5a744b49dd82fc (diff)
downloadgentoo-4fc1a4a28036742d249ee64905dbff0f3a7feb29.tar.gz
gentoo-4fc1a4a28036742d249ee64905dbff0f3a7feb29.tar.xz
dev-ros/rqt_plot: Bump to 0.4.2.
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-ros/rqt_plot')
-rw-r--r--dev-ros/rqt_plot/Manifest1
-rw-r--r--dev-ros/rqt_plot/rqt_plot-0.4.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ros/rqt_plot/Manifest b/dev-ros/rqt_plot/Manifest
index 2785785bc51..2c7ab9e97dc 100644
--- a/dev-ros/rqt_plot/Manifest
+++ b/dev-ros/rqt_plot/Manifest
@@ -1 +1,2 @@
DIST rqt_common_plugins-0.4.1.tar.gz 239721 SHA256 0fc1b6d443e346157baa7814f23e85ac58fc4d9a3010dd0164b9c2edbb5acc39 SHA512 41c568beccab0332fa8282ba8110e0f3ae92c617d3a0eddbc5692d3ba23c8407c46d37957751e84c3ec1c39984264fa507bc266a96d9b7cbaf07678e52a504ed WHIRLPOOL d1b8d3cf1dd285a3281b1ff7dd395377d3ee520f2c597c4e73c5ff8c6305d4c35c4705b48b4e01167cf802f8f5cc88b0c0aee5e9dd223dda42de93321bbc2bc4
+DIST rqt_common_plugins-0.4.2.tar.gz 241741 SHA256 6647c4cf40ed49804beca8a45927f78ac0274c37bd4e9f0ed629d20f92549173 SHA512 e83b4f50aadb3ee1b5c696b95b024ea55d39eaff113da8ecdc9f7f28ba97853c92b88438e02c18c3650874e13b14aacb5be0c6f426552e41c85b8cfe5ff48992 WHIRLPOOL fac39062a4a093877040c2cb21c8fbb83e7bf820ea8a18a95183c447622699927f0edb5e9beab2c907f927a4476c292f4906a9f8af6b0f995b377f752f1a8ce7
diff --git a/dev-ros/rqt_plot/rqt_plot-0.4.2.ebuild b/dev-ros/rqt_plot/rqt_plot-0.4.2.ebuild
new file mode 100644
index 00000000000..3417a23c204
--- /dev/null
+++ b/dev-ros/rqt_plot/rqt_plot-0.4.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin visualizing numeric values in a 2D plot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ || ( dev-python/matplotlib[${PYTHON_USEDEP}] dev-python/pyqwt:5[${PYTHON_USEDEP}] )
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.2.19[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"