summaryrefslogtreecommitdiff
path: root/dev-ros/test_roslib_comm/test_roslib_comm-1.11.15.ebuild
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-15 11:33:36 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-15 13:25:34 +0200
commit044919a0340de182d3ebb1f6f254e4dc89aeb22f (patch)
tree609574176c6a6862faea63496e63ed75b068935a /dev-ros/test_roslib_comm/test_roslib_comm-1.11.15.ebuild
parent6f932f142195f7700e28ef1f7c174cd581920726 (diff)
downloadgentoo-044919a0340de182d3ebb1f6f254e4dc89aeb22f.tar.gz
gentoo-044919a0340de182d3ebb1f6f254e4dc89aeb22f.tar.xz
dev-ros/test_roslib_comm: Bump to 1.11.15.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/test_roslib_comm/test_roslib_comm-1.11.15.ebuild')
-rw-r--r--dev-ros/test_roslib_comm/test_roslib_comm-1.11.15.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/test_roslib_comm/test_roslib_comm-1.11.15.ebuild b/dev-ros/test_roslib_comm/test_roslib_comm-1.11.15.ebuild
new file mode 100644
index 00000000000..d37b72324b8
--- /dev/null
+++ b/dev-ros/test_roslib_comm/test_roslib_comm-1.11.15.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=test/${PN}
+CATKIN_HAS_MESSAGES=yes
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/rosgraph_msgs dev-ros/std_msgs"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit ros-catkin
+
+DESCRIPTION="Unit tests for roslib"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( dev-ros/roslib[${PYTHON_USEDEP}] dev-python/nose[${PYTHON_USEDEP}] dev-ros/test_rosmaster )
+"