summaryrefslogtreecommitdiff
path: root/dev-ros/turtle_actionlib
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-22 18:12:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-22 18:12:50 +0200
commit20da6d20a231a10f4183c5ca5e9e4d0479bdd8d4 (patch)
treee92b89d16d5fe0a2189435d3c2f6e4301805bef5 /dev-ros/turtle_actionlib
parent5af8fc2c7b0bff9cc73c1589404169c009c2bbe3 (diff)
downloadgentoo-20da6d20a231a10f4183c5ca5e9e4d0479bdd8d4.tar.gz
gentoo-20da6d20a231a10f4183c5ca5e9e4d0479bdd8d4.tar.xz
dev-ros/turtle_actionlib: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/turtle_actionlib')
-rw-r--r--dev-ros/turtle_actionlib/Manifest1
-rw-r--r--dev-ros/turtle_actionlib/metadata.xml5
-rw-r--r--dev-ros/turtle_actionlib/turtle_actionlib-0.1.8.ebuild28
-rw-r--r--dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild28
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-ros/turtle_actionlib/Manifest b/dev-ros/turtle_actionlib/Manifest
new file mode 100644
index 00000000000..c0f80a822bb
--- /dev/null
+++ b/dev-ros/turtle_actionlib/Manifest
@@ -0,0 +1 @@
+DIST common_tutorials-0.1.8.tar.gz 10591 SHA256 5be04cdcfbc569d7b89c306628fd4414a3e2972ad2154548df2b86d4056393d9 SHA512 a0a2e8a7aba3415bf133e95e7d1b72cf5ee81efa962003ccaa2108fdfebd2a03044c60fd4daf73ca69f3a2975bd7fa9c60adfefc32d1b048da11e65aa613607c WHIRLPOOL dd60f2c2c760c4f3485ec670af0a0140569535640886268f329e6088fa19279703489b361d51ba9bbd8cb05194f63376b11983e1709e1f5063dc6e28453a0685
diff --git a/dev-ros/turtle_actionlib/metadata.xml b/dev-ros/turtle_actionlib/metadata.xml
new file mode 100644
index 00000000000..c42ea5b15cf
--- /dev/null
+++ b/dev-ros/turtle_actionlib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/turtle_actionlib/turtle_actionlib-0.1.8.ebuild b/dev-ros/turtle_actionlib/turtle_actionlib-0.1.8.ebuild
new file mode 100644
index 00000000000..c2135ca855b
--- /dev/null
+++ b/dev-ros/turtle_actionlib/turtle_actionlib-0.1.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates how to write an action server and client with the turtlesim"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ dev-ros/actionlib_msgs
+ dev-ros/angles
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/turtlesim
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild b/dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild
new file mode 100644
index 00000000000..c2135ca855b
--- /dev/null
+++ b/dev-ros/turtle_actionlib/turtle_actionlib-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+CATKIN_HAS_MESSAGES=yes
+PYTHON_COMPAT=( python2_7 )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Demonstrates how to write an action server and client with the turtlesim"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib
+ dev-ros/actionlib_msgs
+ dev-ros/angles
+ dev-ros/rosconsole
+ dev-ros/roscpp
+ dev-ros/turtlesim
+"
+DEPEND="${RDEPEND}"