summaryrefslogtreecommitdiff
path: root/dev-ros
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-11-02 09:56:08 +0100
committerAlexis Ballier <aballier@gentoo.org>2015-11-02 09:56:08 +0100
commit0d168f929fa3ab3ce9c751cbd270d40baad7234b (patch)
tree486d12b00cd54ff82745c1da065b8e5f1915b4d9 /dev-ros
parentd825b55d90afbb583a24de11d498d730d749a464 (diff)
downloadgentoo-0d168f929fa3ab3ce9c751cbd270d40baad7234b.tar.gz
gentoo-0d168f929fa3ab3ce9c751cbd270d40baad7234b.tar.xz
dev-ros/shape_tools: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/shape_tools/Manifest1
-rw-r--r--dev-ros/shape_tools/metadata.xml5
-rw-r--r--dev-ros/shape_tools/shape_tools-0.2.1.ebuild28
-rw-r--r--dev-ros/shape_tools/shape_tools-9999.ebuild28
4 files changed, 62 insertions, 0 deletions
diff --git a/dev-ros/shape_tools/Manifest b/dev-ros/shape_tools/Manifest
new file mode 100644
index 00000000000..fb4b451adf1
--- /dev/null
+++ b/dev-ros/shape_tools/Manifest
@@ -0,0 +1 @@
+DIST shape_tools-0.2.1.tar.gz 3684 SHA256 19a11713c78e409a466bca5168a7710e096a92f92fcafef4fa485bc7606eaf3e SHA512 4d6da49528518776cb51ace908f0f0326b31b2928f0cb8ae0b12bcb0c1fdac99cbcd71f6bd3324d6aecc38a68a10012535b914a2349925eab1487eed8e1bede3 WHIRLPOOL 01a59f454e70c218c033d8af10612ab8897fe523f806a565f397876015b6a293cebd20f66511723d40034dbf33a29c1fbe68635e0b0569ddf100ed5c99efb2b4
diff --git a/dev-ros/shape_tools/metadata.xml b/dev-ros/shape_tools/metadata.xml
new file mode 100644
index 00000000000..c42ea5b15cf
--- /dev/null
+++ b/dev-ros/shape_tools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/shape_tools/shape_tools-0.2.1.ebuild b/dev-ros/shape_tools/shape_tools-0.2.1.ebuild
new file mode 100644
index 00000000000..55a40297618
--- /dev/null
+++ b/dev-ros/shape_tools/shape_tools-0.2.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-planning/shape_tools"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for operating on shape messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/shape_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+ -i CMakeLists.txt \
+ || die
+}
diff --git a/dev-ros/shape_tools/shape_tools-9999.ebuild b/dev-ros/shape_tools/shape_tools-9999.ebuild
new file mode 100644
index 00000000000..55a40297618
--- /dev/null
+++ b/dev-ros/shape_tools/shape_tools-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-planning/shape_tools"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for operating on shape messages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/visualization_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/shape_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+ -i CMakeLists.txt \
+ || die
+}