summaryrefslogtreecommitdiff
path: root/dev-ros
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-23 08:58:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-23 09:30:35 +0200
commit97401dff08876435ca7225336a0ab6d18c2ce856 (patch)
tree288902035f3f63835c4624bd53e250fc63989cb8 /dev-ros
parentd25ec4c99c125b99054729945c443eaa5a255f31 (diff)
downloadgentoo-97401dff08876435ca7225336a0ab6d18c2ce856.tar.gz
gentoo-97401dff08876435ca7225336a0ab6d18c2ce856.tar.xz
dev-ros/actionlib: bump to 1.11.10
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/actionlib/Manifest1
-rw-r--r--dev-ros/actionlib/actionlib-1.11.10.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/actionlib/Manifest b/dev-ros/actionlib/Manifest
index e87a060c643..d5076882c12 100644
--- a/dev-ros/actionlib/Manifest
+++ b/dev-ros/actionlib/Manifest
@@ -1 +1,2 @@
+DIST actionlib-1.11.10.tar.gz 98375 SHA256 8a4e9d71e23916abcab9892bd6c9890a691267d73ec4eed2034c307d57409619 SHA512 afb28c568910a2786ea3e97c89ee6b02b4c33335b05f466219bc17cd5bd8e021de3bbbd3ae0cef0b46915442549dba84e9a655169e9c95e1ae62071d015e00e3 WHIRLPOOL 85d84684ec7d64a34b13ca08ef337af83e15738901ad273445487e7977b1fb6677a92d33d7e2d5314407c986aee7e54aa862e4b2599be0739e1110a369abdbd1
DIST actionlib-1.11.9.tar.gz 98000 SHA256 0e0eb18e964cfd25490875295950760fb468fd30cab707c0138ddada131be7c6 SHA512 a331f10aeeaf33b5074c637866157a317af0a8bf4ff17960cc5dc6e12970ab59cdf9bc032d3aea2704b00ee0d3404572f83ddbfc9d68cf41430300ed885af60b WHIRLPOOL ccf24dade14dd4da1a370a05cfe22c94424a2cb63449657350c783dc9f94bec72d3ec723ef7a9b5fcf518bdd4a502cf05268578d6a08d730373a1b7516807ec5
diff --git a/dev-ros/actionlib/actionlib-1.11.10.ebuild b/dev-ros/actionlib/actionlib-1.11.10.ebuild
new file mode 100644
index 00000000000..037b0253aa2
--- /dev/null
+++ b/dev-ros/actionlib/actionlib-1.11.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+CATKIN_HAS_MESSAGES=yes
+ROS_REPO_URI="https://github.com/ros/actionlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Provides a standardized interface for interfacing with preemptable tasks"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:=[threads]
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ dev-ros/rosunit[${PYTHON_USEDEP}]
+ test? ( dev-ros/rostest[${PYTHON_USEDEP}] )"