summaryrefslogtreecommitdiff
path: root/dev-ros
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 14:16:57 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 16:34:21 +0200
commitd7e6c2b2d4c3ae0cb7ab56167a044af01b17086a (patch)
tree61c529c0484c4de9d30e8c07c6c7643d1cbd5a3e /dev-ros
parent67b05abe9e7a7172120f76565c1b72610282f00a (diff)
downloadgentoo-d7e6c2b2d4c3ae0cb7ab56167a044af01b17086a.tar.gz
gentoo-d7e6c2b2d4c3ae0cb7ab56167a044af01b17086a.tar.xz
dev-ros/settlerlib: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/settlerlib/Manifest1
-rw-r--r--dev-ros/settlerlib/metadata.xml5
-rw-r--r--dev-ros/settlerlib/settlerlib-0.10.13.ebuild23
-rw-r--r--dev-ros/settlerlib/settlerlib-9999.ebuild23
4 files changed, 52 insertions, 0 deletions
diff --git a/dev-ros/settlerlib/Manifest b/dev-ros/settlerlib/Manifest
new file mode 100644
index 00000000000..38907048959
--- /dev/null
+++ b/dev-ros/settlerlib/Manifest
@@ -0,0 +1 @@
+DIST calibration-0.10.13.tar.gz 112305 SHA256 935755f9428e6b998d1a9ce10fcf11f3c119953ebe0b65eda855804ec8b8aea8 SHA512 95b5ea28428ea9726b6b1a8f24cd4c7cb84992e680761357c1a13dd92c362149a0a6104f6a44dbefad503db1a9c7a53135d9756b1ceea3a739b1baa14f9474eb WHIRLPOOL 94423d70268b053daee1da1b324582d2f8316c6feaa5c9291715b1861520cb2e67654daaa2156e8d15cd59ecb566bdd3cb76d42c7202b85680888bac3532002c
diff --git a/dev-ros/settlerlib/metadata.xml b/dev-ros/settlerlib/metadata.xml
new file mode 100644
index 00000000000..c42ea5b15cf
--- /dev/null
+++ b/dev-ros/settlerlib/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/settlerlib/settlerlib-0.10.13.ebuild b/dev-ros/settlerlib/settlerlib-0.10.13.ebuild
new file mode 100644
index 00000000000..13928c60381
--- /dev/null
+++ b/dev-ros/settlerlib/settlerlib-0.10.13.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Helper functions and routines to help creating a settler for a specific sensor channel"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/settlerlib/settlerlib-9999.ebuild b/dev-ros/settlerlib/settlerlib-9999.ebuild
new file mode 100644
index 00000000000..13928c60381
--- /dev/null
+++ b/dev-ros/settlerlib/settlerlib-9999.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Helper functions and routines to help creating a settler for a specific sensor channel"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/calibration_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/rostime
+"
+DEPEND="${RDEPEND}"