summaryrefslogtreecommitdiff
path: root/dev-ruby/arel-helpers/arel-helpers-2.1.1.ebuild
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-11-01 07:24:58 +0100
committerHans de Graaff <graaff@gentoo.org>2015-11-01 07:26:07 +0100
commit8c8bd8152a74e50846a27e757b793f90b0e79fdc (patch)
tree09a2bd69ddf344de9311cd5ba1d8f567c6f2b9c9 /dev-ruby/arel-helpers/arel-helpers-2.1.1.ebuild
parenta84e0727513499ae783809d2d3b4a8e05ec770c2 (diff)
downloadgentoo-8c8bd8152a74e50846a27e757b793f90b0e79fdc.tar.gz
gentoo-8c8bd8152a74e50846a27e757b793f90b0e79fdc.tar.xz
dev-ruby/arel-helpers: add 2.1.1
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/arel-helpers/arel-helpers-2.1.1.ebuild')
-rw-r--r--dev-ruby/arel-helpers/arel-helpers-2.1.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/arel-helpers/arel-helpers-2.1.1.ebuild b/dev-ruby/arel-helpers/arel-helpers-2.1.1.ebuild
new file mode 100644
index 00000000000..95e0b071f41
--- /dev/null
+++ b/dev-ruby/arel-helpers/arel-helpers-2.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Tools to help construct database queries"
+HOMEPAGE="https://github.com/camertron/arel-helpers"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend "|| ( dev-ruby/activerecord:3.2
+ dev-ruby/activerecord:4.0
+ dev-ruby/activerecord:4.1
+ dev-ruby/activerecord:4.2 )"
+
+ruby_add_bdepend "test? (
+ dev-ruby/rr
+ dev-ruby/activerecord[sqlite]
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/pry-nav/ s:^:#:' spec/spec_helper.rb || die
+}