summaryrefslogtreecommitdiff
path: root/dev-ruby/chunky_png/chunky_png-1.3.8.ebuild
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-11-12 07:51:57 +0100
committerHans de Graaff <graaff@gentoo.org>2016-11-12 07:51:57 +0100
commit64b1879f1044be43e8a0fa7dd22825612814dddb (patch)
treea4dfbe1351ec81f709b2c0087721d2990fbbccff /dev-ruby/chunky_png/chunky_png-1.3.8.ebuild
parent17105caf375fc63e580f99c43bcf2b57184b54f0 (diff)
downloadgentoo-64b1879f1044be43e8a0fa7dd22825612814dddb.tar.gz
gentoo-64b1879f1044be43e8a0fa7dd22825612814dddb.tar.xz
dev-ruby/chunky_png: add 1.3.8
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ruby/chunky_png/chunky_png-1.3.8.ebuild')
-rw-r--r--dev-ruby/chunky_png/chunky_png-1.3.8.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/chunky_png/chunky_png-1.3.8.ebuild b/dev-ruby/chunky_png/chunky_png-1.3.8.ebuild
new file mode 100644
index 00000000000..349dfe0b52f
--- /dev/null
+++ b/dev-ruby/chunky_png/chunky_png-1.3.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+
+RUBY_FAKEGEM_EXTRADOC="BENCHMARKING.rdoc CHANGELOG.rdoc README.md"
+
+RUBY_FAKEGEM_GEMSPEC="chunky_png.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure Ruby library that can read and write PNG images"
+HOMEPAGE="https://wiki.github.com/wvanbergen/chunky_png"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/[bB]undler/s:^:#:' {spec,benchmarks}/*.rb || die
+ rm Gemfile* || die
+
+ # Avoid git dependency
+ sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}