summaryrefslogtreecommitdiff
path: root/dev-ruby/configliere
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/configliere
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/configliere')
-rw-r--r--dev-ruby/configliere/Manifest2
-rw-r--r--dev-ruby/configliere/configliere-0.4.18-r1.ebuild38
-rw-r--r--dev-ruby/configliere/configliere-0.4.22.ebuild37
-rw-r--r--dev-ruby/configliere/files/configliere-0.4.17-nobundler.patch11
-rw-r--r--dev-ruby/configliere/metadata.xml8
5 files changed, 96 insertions, 0 deletions
diff --git a/dev-ruby/configliere/Manifest b/dev-ruby/configliere/Manifest
new file mode 100644
index 00000000000..1db241fc3b2
--- /dev/null
+++ b/dev-ruby/configliere/Manifest
@@ -0,0 +1,2 @@
+DIST configliere-0.4.18.gem 52736 SHA256 3d0769ecbb28111b162c704c4bb3c6d3926b6ba2dd609a481d5d4b6e355cdee2 SHA512 b958002290c8e10d562ccc1b5ec33f116d0d87620ef72c6789e9cca5552bee4f74a63949c8f3c11c709098ae2cc23bcb1c423c3a043472b95035056d848f015b WHIRLPOOL 2492c396067a34d5ba00300be8a523069facd364de621c3487cc214b88c27442f74714c8d908c84f06ff37aec73f3336516a863a08366cc7de7632494ed1281e
+DIST configliere-0.4.22.gem 53760 SHA256 94252eb03bac389b8a9164cf513fcdb0471cbe36368e6a7d8f4f48eecb3d266e SHA512 e5c1acc3bb4a9470bf18071ac2a09407ece4ce6bcb7d6d7931247aae8894f87f2bcfef5890569d9241b6d1fc6dfdbe10ee8fafadf0c9e139a31fad86df88579a WHIRLPOOL 2b522c0ac10ce8fd1d771d8fbd283bd5bdc5344028f24e1766100ea76a958b9a4dd3d9e97f2e7c2f777ad6bf68b0a4ac2ea5923ccde89ad117b666e3dd98a4a0
diff --git a/dev-ruby/configliere/configliere-0.4.18-r1.ebuild b/dev-ruby/configliere/configliere-0.4.18-r1.ebuild
new file mode 100644
index 00000000000..bf44036527e
--- /dev/null
+++ b/dev-ruby/configliere/configliere-0.4.18-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.textile README.textile FEATURES.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Settings manager for Ruby scripts"
+HOMEPAGE="https://github.com/infochimps-labs/configliere"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/highline-1.5.2
+ >=dev-ruby/multi_json-1.1"
+
+RUBY_PATCHES=( ${PN}-0.4.17-nobundler.patch )
+
+all_ruby_prepare() {
+ rm Gemfile* || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}
diff --git a/dev-ruby/configliere/configliere-0.4.22.ebuild b/dev-ruby/configliere/configliere-0.4.22.ebuild
new file mode 100644
index 00000000000..d58ffb659d7
--- /dev/null
+++ b/dev-ruby/configliere/configliere-0.4.22.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.textile README.textile FEATURES.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Settings manager for Ruby scripts"
+HOMEPAGE="https://github.com/infochimps-labs/configliere"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/highline-1.5.2
+ >=dev-ruby/multi_json-1.10.1"
+
+all_ruby_prepare() {
+ rm Gemfile* || die
+ sed -i -e "/bundler/d" spec/spec_helper.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+}
diff --git a/dev-ruby/configliere/files/configliere-0.4.17-nobundler.patch b/dev-ruby/configliere/files/configliere-0.4.17-nobundler.patch
new file mode 100644
index 00000000000..752bfdc0ec7
--- /dev/null
+++ b/dev-ruby/configliere/files/configliere-0.4.17-nobundler.patch
@@ -0,0 +1,11 @@
+Index: configliere-0.4.17/spec/spec_helper.rb
+===================================================================
+--- configliere-0.4.17.orig/spec/spec_helper.rb
++++ configliere-0.4.17/spec/spec_helper.rb
+@@ -1,5 +1,5 @@
+-require 'bundler/setup' ; Bundler.require(:default, :development, :test)
+ require 'rspec/autorun'
++require 'yaml'
+
+ puts "Running specs in version #{RUBY_VERSION} on #{RUBY_PLATFORM} #{RUBY_DESCRIPTION}"
+
diff --git a/dev-ruby/configliere/metadata.xml b/dev-ruby/configliere/metadata.xml
new file mode 100644
index 00000000000..882af0e6de5
--- /dev/null
+++ b/dev-ruby/configliere/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">infochimps-labs/configliere</remote-id>
+ </upstream>
+</pkgmetadata>