summaryrefslogtreecommitdiff
path: root/dev-ruby/cri/cri-2.10.1.ebuild
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-11-02 06:39:27 +0100
committerHans de Graaff <graaff@gentoo.org>2017-11-02 06:39:27 +0100
commit77e6b5637e674978db615c6d374bd894d4096499 (patch)
treead39e0a16a40d92ca313a5fe6fca181f5a0582ee /dev-ruby/cri/cri-2.10.1.ebuild
parenta310bd9e2796b0e400c4ca0adf43e758e49eb0b6 (diff)
downloadgentoo-77e6b5637e674978db615c6d374bd894d4096499.tar.gz
gentoo-77e6b5637e674978db615c6d374bd894d4096499.tar.xz
dev-ruby/cri: add 2.10.1
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/cri/cri-2.10.1.ebuild')
-rw-r--r--dev-ruby/cri/cri-2.10.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/cri/cri-2.10.1.ebuild b/dev-ruby/cri/cri-2.10.1.ebuild
new file mode 100644
index 00000000000..01337421830
--- /dev/null
+++ b/dev-ruby/cri/cri-2.10.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="NEWS.md README.adoc"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Cri is a library for building easy-to-use commandline tools"
+HOMEPAGE="https://rubygems.org/gems/cri"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/colored-1.2"
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/yard dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -e '/coveralls/I s:^:#:' -i test/helper.rb || die
+ sed -i -e '/rubocop/ s:^:#:' \
+ -e '/RuboCop/,/end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib -S rake test_unit || die
+}