summaryrefslogtreecommitdiff
path: root/dev-ruby/gettext_i18n_rails
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/gettext_i18n_rails
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/gettext_i18n_rails')
-rw-r--r--dev-ruby/gettext_i18n_rails/Manifest2
-rw-r--r--dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.2.2.ebuild37
-rw-r--r--dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.2.3.ebuild37
-rw-r--r--dev-ruby/gettext_i18n_rails/metadata.xml8
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-ruby/gettext_i18n_rails/Manifest b/dev-ruby/gettext_i18n_rails/Manifest
new file mode 100644
index 00000000000..8458a74ed24
--- /dev/null
+++ b/dev-ruby/gettext_i18n_rails/Manifest
@@ -0,0 +1,2 @@
+DIST gettext_i18n_rails-1.2.2.tar.gz 20254 SHA256 4bdaff360864211ee8739155f881cbe505d36ae8ec0d592c8180779f6f84a35e SHA512 c2a02a2aaa118581e81b3ff375ebfb8b4e58fc2313e8d7f321d881370b546d906eec51f848d27f2996ca16938bc7580ed6c27d780d1531a251578ce9260bcb40 WHIRLPOOL c674993506104a8475b7a2be422f11558aa001f362cdc7786fc27cf3b44368ce5855a0ecdc555e28345ad81cd14c70d785c5952cd8bbf6506a0720534c658d38
+DIST gettext_i18n_rails-1.2.3.tar.gz 20252 SHA256 48af9946c8165ece5c1c94c01045596e25f00bc679e3eb835e45992663444fd7 SHA512 b28bea0100ca5dd307ead1b77f4e71b491eb12899d772394c6e3ea73150ef4277c7305de0dfd2429ccc635af462f0b0f4f42280cdb666ebc7cee2cf9a43a04a2 WHIRLPOOL f54222b9940b58e16a2e1e27eb36d044ae42fe4b9ed1e06edeb57f5ea1e1ebc727de1cd564cd3679f0851b47fc5ebe93d3913a2ef90de8ebd56917a08ba19913
diff --git a/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.2.2.ebuild b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.2.2.ebuild
new file mode 100644
index 00000000000..03ffeecd1df
--- /dev/null
+++ b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="FastGettext / Rails integration"
+HOMEPAGE="https://github.com/grosser/gettext_i18n_rails"
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activerecord:4.0[sqlite] dev-ruby/temple )"
+ruby_add_rdepend ">=dev-ruby/fast_gettext-0.9.0"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+
+ # Remove specs for slim and hamlet, template engines we don't package.
+ rm spec/gettext_i18n_rails/slim_parser_spec.rb spec/gettext_i18n_rails/haml_parser_spec.rb || die
+
+ # Test against Rails 4.0 (newer versions don't work and we don't use
+ # appraisals for now).
+ sed -e '1igem "rails", "~>4.0.0"' -i spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.2.3.ebuild b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.2.3.ebuild
new file mode 100644
index 00000000000..4a15b6b8c07
--- /dev/null
+++ b/dev-ruby/gettext_i18n_rails/gettext_i18n_rails-1.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="FastGettext / Rails integration"
+HOMEPAGE="https://github.com/grosser/gettext_i18n_rails"
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rails:4.0 dev-ruby/activerecord:4.0[sqlite] dev-ruby/temple )"
+ruby_add_rdepend ">=dev-ruby/fast_gettext-0.9.0"
+
+all_ruby_prepare() {
+ rm Gemfile Gemfile.lock || die
+
+ # Remove specs for slim and hamlet, template engines we don't package.
+ rm spec/gettext_i18n_rails/slim_parser_spec.rb spec/gettext_i18n_rails/haml_parser_spec.rb || die
+
+ # Test against Rails 4.0 (newer versions don't work and we don't use
+ # appraisals for now).
+ sed -e '1igem "rails", "~>4.0.0"' -i spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/gettext_i18n_rails/metadata.xml b/dev-ruby/gettext_i18n_rails/metadata.xml
new file mode 100644
index 00000000000..9df2f553e8e
--- /dev/null
+++ b/dev-ruby/gettext_i18n_rails/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">grosser/gettext_i18n_rails</remote-id>
+ </upstream>
+</pkgmetadata>