summaryrefslogtreecommitdiff
path: root/dev-ruby/hike
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/hike
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/hike')
-rw-r--r--dev-ruby/hike/Manifest2
-rw-r--r--dev-ruby/hike/hike-1.2.3-r1.ebuild26
-rw-r--r--dev-ruby/hike/hike-1.2.3.ebuild26
-rw-r--r--dev-ruby/hike/hike-2.1.2.ebuild24
-rw-r--r--dev-ruby/hike/metadata.xml8
5 files changed, 86 insertions, 0 deletions
diff --git a/dev-ruby/hike/Manifest b/dev-ruby/hike/Manifest
new file mode 100644
index 00000000000..f43a1335f09
--- /dev/null
+++ b/dev-ruby/hike/Manifest
@@ -0,0 +1,2 @@
+DIST hike-1.2.3.tgz 9010 SHA256 0dbb22f1596ec0a5261e454028ce36661b4185b4527bfd98c365495f03234833 SHA512 0d7a35c0f9b4f5f1f99d4b2b753244cb712ebc24cc54b366c60ac6094a2ec693df86443e0b4499358cdd4f6411347ad80e0fc90b5fb7f4dd9b627832b645adcd WHIRLPOOL daf6673ac9f57b50f663c66c083e93de3c31c792803799d0a98c630a89338a21c5c27f6e641f0e781f1dc53ebf667bb128397bca8ef0934e16ea3d7ad18a3d04
+DIST hike-2.1.2.tgz 9111 SHA256 599732124a5b5f0a67694c7e12d1f55480e1fb0e0846e6ffe952b7202b872ed9 SHA512 fc05b6ec5676d5b6d12273688b0f98cd01784e201947293c5af92c637adcd9cd788fa9a696d6439efcc9097e540160fb96133dffd85289e498042acce8ca0c97 WHIRLPOOL fb6b4f095aa02fc27f81c52daad1f18ad63f388931934b440a061fd68e2cbce8b8e53701e8d067ef5d6a82e50c4a156d30da8afd18b64db16009faee99dc9951
diff --git a/dev-ruby/hike/hike-1.2.3-r1.ebuild b/dev-ruby/hike/hike-1.2.3-r1.ebuild
new file mode 100644
index 00000000000..a88c13ccc96
--- /dev/null
+++ b/dev-ruby/hike/hike-1.2.3-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hike is a Ruby library for finding files in a set of paths"
+HOMEPAGE="https://github.com/sstephenson/hike"
+LICENSE="MIT"
+SRC_URI="https://github.com/sstephenson/hike/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test -S testrb test || die
+}
diff --git a/dev-ruby/hike/hike-1.2.3.ebuild b/dev-ruby/hike/hike-1.2.3.ebuild
new file mode 100644
index 00000000000..5b3aa211adc
--- /dev/null
+++ b/dev-ruby/hike/hike-1.2.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hike is a Ruby library for finding files in a set of paths"
+HOMEPAGE="https://github.com/sstephenson/hike"
+LICENSE="MIT"
+SRC_URI="https://github.com/sstephenson/hike/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test -S testrb test || die
+}
diff --git a/dev-ruby/hike/hike-2.1.2.ebuild b/dev-ruby/hike/hike-2.1.2.ebuild
new file mode 100644
index 00000000000..86117565dcd
--- /dev/null
+++ b/dev-ruby/hike/hike-2.1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hike is a Ruby library for finding files in a set of paths"
+HOMEPAGE="https://github.com/sstephenson/hike"
+LICENSE="MIT"
+SRC_URI="https://github.com/sstephenson/hike/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+SLOT="2"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
diff --git a/dev-ruby/hike/metadata.xml b/dev-ruby/hike/metadata.xml
new file mode 100644
index 00000000000..dd46ca7bbdc
--- /dev/null
+++ b/dev-ruby/hike/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">sstephenson/hike</remote-id>
+ </upstream>
+</pkgmetadata>