summaryrefslogtreecommitdiff
path: root/dev-ruby/httparty
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/httparty
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/Manifest2
-rw-r--r--dev-ruby/httparty/httparty-0.13.4.ebuild49
-rw-r--r--dev-ruby/httparty/httparty-0.13.5.ebuild49
-rw-r--r--dev-ruby/httparty/metadata.xml5
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-ruby/httparty/Manifest b/dev-ruby/httparty/Manifest
new file mode 100644
index 00000000000..ac9190a4838
--- /dev/null
+++ b/dev-ruby/httparty/Manifest
@@ -0,0 +1,2 @@
+DIST httparty-0.13.4.gem 78848 SHA256 5dea492ff272e8417fc89730c5166944d0a4b41293d7344c1a0de9e804ef9cde SHA512 7f544c3df689e413bfa47798ccc9bea295d00c084ed15da32f105e68ae40bc12c49f3e90e4cde0d147037a94f88f4130143d164e3afd3a069fa8e7b8bb2f8265 WHIRLPOOL e7ac75dce16b3b5e558d58b9519f8fb617265c883e60f780a9abb0c6e31983685990a9b589287fd3cf128be29ee26f70fe305385443487beb3c9d2d1ff93d589
+DIST httparty-0.13.5.gem 78848 SHA256 c9b9a31d80af2e5bc5e2a7c37efc5d8aad4c8d9c58b82f18e4ff37cfef7223d5 SHA512 d8408ea085d71d1a3b80519834173618e283c806ecef25f0a2c6029eee23a0f8e07218ac018dbb884a78e9b0e4e91bad11228112811cefb39e2b8a517fce1880 WHIRLPOOL e7b7b8d299ef4d1cb4dd45189044dbdfa357159f01f9743f35664d1820c9309fac96d6e803ed9bd09f626e5411438ff310dfe3c0bc4803973c53c1808a13e4a3
diff --git a/dev-ruby/httparty/httparty-0.13.4.ebuild b/dev-ruby/httparty/httparty-0.13.4.ebuild
new file mode 100644
index 00000000000..111bb8a9509
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.13.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# We have a custom test function, but don't null this out so that the
+# deps are still added
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md History"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
+HOMEPAGE="http://jnunemaker.github.com/httparty"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/json-1.8:0 >=dev-ruby/multi_xml-0.5.2'
+
+ruby_add_bdepend 'dev-ruby/rspec:3 dev-ruby/fakeweb'
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid test dependency on cucumber. We can't run the features since
+ # they depend on mongrel which is no longer packaged.
+ sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rake spec || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}
diff --git a/dev-ruby/httparty/httparty-0.13.5.ebuild b/dev-ruby/httparty/httparty-0.13.5.ebuild
new file mode 100644
index 00000000000..111bb8a9509
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.13.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+# We have a custom test function, but don't null this out so that the
+# deps are still added
+RUBY_FAKEGEM_TASK_TEST="none"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md History"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
+HOMEPAGE="http://jnunemaker.github.com/httparty"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/json-1.8:0 >=dev-ruby/multi_xml-0.5.2'
+
+ruby_add_bdepend 'dev-ruby/rspec:3 dev-ruby/fakeweb'
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid test dependency on cucumber. We can't run the features since
+ # they depend on mongrel which is no longer packaged.
+ sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S rake spec || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}
diff --git a/dev-ruby/httparty/metadata.xml b/dev-ruby/httparty/metadata.xml
new file mode 100644
index 00000000000..85213618336
--- /dev/null
+++ b/dev-ruby/httparty/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>