summaryrefslogtreecommitdiff
path: root/dev-ruby/itextomml
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/itextomml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/itextomml')
-rw-r--r--dev-ruby/itextomml/Manifest1
-rw-r--r--dev-ruby/itextomml/itextomml-1.5.2.ebuild35
-rw-r--r--dev-ruby/itextomml/metadata.xml5
3 files changed, 41 insertions, 0 deletions
diff --git a/dev-ruby/itextomml/Manifest b/dev-ruby/itextomml/Manifest
new file mode 100644
index 00000000000..22d04410cdb
--- /dev/null
+++ b/dev-ruby/itextomml/Manifest
@@ -0,0 +1 @@
+DIST itextomml-1.5.2.gem 124928 SHA256 2fb0a794f5e8628aeae0d098ee67c010ae6793e162785b72baac60890922bcfa SHA512 dbd7a724d65905a322f05bbd9cde1cfbd0b4dd447a358c47f4a983ebf3934d69b938b5f78fde5975d4ed65898dbec9e318b274a919dfc80eac83353a3b6771d7 WHIRLPOOL 2eba813ee3a4fb45eab6325b3fbc0d4d9bb8fac4916450b00966e67bb847356b33aecd3022913c1cb5f878bd50b34942218df3fe967086e7b326fd968f62f5cb
diff --git a/dev-ruby/itextomml/itextomml-1.5.2.ebuild b/dev-ruby/itextomml/itextomml-1.5.2.ebuild
new file mode 100644
index 00000000000..91c46bffc00
--- /dev/null
+++ b/dev-ruby/itextomml/itextomml-1.5.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="Native Ruby bindings to itex2MML, which converts itex equations to MathML"
+HOMEPAGE="http://golem.ph.utexas.edu/~distler/blog/itex2MML.html"
+
+LICENSE="|| ( GPL-2+ MPL-1.1 LGPL-2+ )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+#Tests don't fail here
+RESTRICT="test"
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext
+ cp ext/itex2MML$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/test_itextomml.rb || die
+}
diff --git a/dev-ruby/itextomml/metadata.xml b/dev-ruby/itextomml/metadata.xml
new file mode 100644
index 00000000000..ed77b4f90bc
--- /dev/null
+++ b/dev-ruby/itextomml/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+</pkgmetadata>