summaryrefslogtreecommitdiff
path: root/dev-ruby/jeweler
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/jeweler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/jeweler')
-rw-r--r--dev-ruby/jeweler/Manifest1
-rw-r--r--dev-ruby/jeweler/jeweler-2.0.1-r1.ebuild58
-rw-r--r--dev-ruby/jeweler/jeweler-2.0.1-r2.ebuild58
-rw-r--r--dev-ruby/jeweler/metadata.xml5
4 files changed, 122 insertions, 0 deletions
diff --git a/dev-ruby/jeweler/Manifest b/dev-ruby/jeweler/Manifest
new file mode 100644
index 00000000000..223382dba8f
--- /dev/null
+++ b/dev-ruby/jeweler/Manifest
@@ -0,0 +1 @@
+DIST jeweler-2.0.1.gem 58368 SHA256 2f8c325789f9bf63d273cb040eae2f9ac4271789e5587edbc2d4d22de5ec2882 SHA512 296f661b0e782353bcd166be04501b9f792a9edbc72bddb21c6322e99b0d1da6a03b9f31a19b9daa6d26e18cdbb37cfd7856c91f6befbb920b633fa22d81c41c WHIRLPOOL 9406b5453eb95f14df0696df241e84d54fd80512e6cf7f62bf230bb958ac0bfcb762a1d811ddb35ea9942788cfdc692b0430269e5d378653b24e3c5072b24e8e
diff --git a/dev-ruby/jeweler/jeweler-2.0.1-r1.ebuild b/dev-ruby/jeweler/jeweler-2.0.1-r1.ebuild
new file mode 100644
index 00000000000..9fc7660332a
--- /dev/null
+++ b/dev-ruby/jeweler/jeweler-2.0.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC="-Ilib yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+# Tests and features also need the same set of dependencies present.
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.markdown README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="jeweler.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rake tasks for managing gems and versioning and a generator for creating a new project"
+HOMEPAGE="http://wiki.github.com/technicalpickles/jeweler"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/shoulda dev-ruby/rr dev-ruby/test_construct dev-ruby/test-unit:0 )"
+
+ruby_add_rdepend "
+ dev-ruby/rake
+ >=dev-ruby/git-1.2.5
+ >=dev-ruby/nokogiri-1.5.10
+ dev-ruby/github_api
+ >=dev-ruby/highline-1.6.15
+ >=dev-ruby/bundler-1.0
+ dev-ruby/rdoc
+ dev-ruby/builder:*
+"
+
+all_ruby_prepare() {
+ # Remove bundler support.
+ rm Gemfile || die
+ sed -i -e '/bundler/d' -e '/Bundler.setup/d' Rakefile test/test_helper.rb features/support/env.rb || die
+
+ sed -i -e '/coverall/I s:^:#:' \
+ -e '1i gem "test-unit", "~> 1.0"' test/test_helper.rb || die
+
+ # Avoid a test that only passes in the git repository.
+ sed -i -e '/find the base repo/,/^ end/ s:^:#:' test/test_jeweler.rb || die
+
+ # Use a non-deprecated version of construct
+ sed -i -e 's/construct/test_construct/' -e 's/Construct/TestConstruct/' test/test_helper.rb || die
+
+ # Avoid dependency on cucumber
+ sed -i -e '/cucumber/,$ s:^:#:' Rakefile || die
+}
diff --git a/dev-ruby/jeweler/jeweler-2.0.1-r2.ebuild b/dev-ruby/jeweler/jeweler-2.0.1-r2.ebuild
new file mode 100644
index 00000000000..0f4427bec1e
--- /dev/null
+++ b/dev-ruby/jeweler/jeweler-2.0.1-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC="-Ilib yard"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+# Tests and features also need the same set of dependencies present.
+RUBY_FAKEGEM_TASK_TEST="-Ilib test"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.markdown README.markdown"
+
+RUBY_FAKEGEM_GEMSPEC="jeweler.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Rake tasks for managing gems and versioning and a generator for creating a new project"
+HOMEPAGE="http://wiki.github.com/technicalpickles/jeweler"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/shoulda dev-ruby/rr dev-ruby/test_construct dev-ruby/test-unit:0 )"
+
+ruby_add_rdepend "
+ dev-ruby/rake
+ >=dev-ruby/git-1.2.5
+ >=dev-ruby/nokogiri-1.5.10
+ dev-ruby/github_api
+ >=dev-ruby/highline-1.6.15
+ >=dev-ruby/bundler-1.0
+ dev-ruby/rdoc
+ dev-ruby/builder:*
+"
+
+all_ruby_prepare() {
+ # Remove bundler support.
+ rm Gemfile || die
+ sed -i -e '/bundler/d' -e '/Bundler.setup/d' Rakefile test/test_helper.rb features/support/env.rb || die
+
+ sed -i -e '/coverall/I s:^:#:' \
+ -e '1i gem "test-unit", "~> 1.0"' test/test_helper.rb || die
+
+ # Avoid a test that only passes in the git repository.
+ sed -i -e '/find the base repo/,/^ end/ s:^:#:' test/test_jeweler.rb || die
+
+ # Use a non-deprecated version of construct
+ sed -i -e 's/construct/test_construct/' -e 's/Construct/TestConstruct/' test/test_helper.rb || die
+
+ # Avoid dependency on cucumber
+ sed -i -e '/cucumber/,$ s:^:#:' Rakefile || die
+}
diff --git a/dev-ruby/jeweler/metadata.xml b/dev-ruby/jeweler/metadata.xml
new file mode 100644
index 00000000000..85213618336
--- /dev/null
+++ b/dev-ruby/jeweler/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ruby</herd>
+</pkgmetadata>