summaryrefslogtreecommitdiff
path: root/dev-ruby/libxml
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/libxml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/libxml')
-rw-r--r--dev-ruby/libxml/Manifest1
-rw-r--r--dev-ruby/libxml/libxml-2.8.0-r1.ebuild64
-rw-r--r--dev-ruby/libxml/libxml-2.8.0.ebuild64
-rw-r--r--dev-ruby/libxml/metadata.xml8
4 files changed, 137 insertions, 0 deletions
diff --git a/dev-ruby/libxml/Manifest b/dev-ruby/libxml/Manifest
new file mode 100644
index 00000000000..dc226f3d4fb
--- /dev/null
+++ b/dev-ruby/libxml/Manifest
@@ -0,0 +1 @@
+DIST libxml-ruby-2.8.0.gem 261120 SHA256 0bd2780afaaf944d38786999d929a4fd37eb30922c404301b86dee94c9c512b6 SHA512 085670e0d343d47085d03d7d95a94498e7be049fbab5e60f1c5f43f9fc41222fe96315de7d5b12b221a3c866d0c178dbfbe2e717a206cce8c4471a2b3ddb9c42 WHIRLPOOL bae7fe3e885b35c58e314cf84ecf0f09abb754e4d41e047b101f20fc2d62f7695e328f8cc07f91d473de87ceb82c2a54d37ea4cb03c421897a5d539605883400
diff --git a/dev-ruby/libxml/libxml-2.8.0-r1.ebuild b/dev-ruby/libxml/libxml-2.8.0-r1.ebuild
new file mode 100644
index 00000000000..935209384c3
--- /dev/null
+++ b/dev-ruby/libxml/libxml-2.8.0-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby22 → test suite hangs
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster"
+HOMEPAGE="https://github.com/xml4r/libxml-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/libxml2"
+DEPEND="${DEPEND} dev-libs/libxml2"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ # Remove grancher tasks only needed for publishing the website
+ sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
+
+ # We don't have the hanna template available.
+ sed -i -e 's/hanna/rake/' Rakefile || die
+
+ # Remove rake-compiler bits since we don't use it
+ sed -i -e '/extensiontask/d' -e '/ExtensionTask/,/end/d' -e '/GemPackageTask/,/end/d' Rakefile || die
+
+ # replace ulimit -n output as it does not work with Ruby 1.9
+ sed -i -e 's:`ulimit -n`:"'`ulimit -n`'":' test/tc_parser.rb || die
+
+ # Avoid test failures with libxml2-2.9.2 since that is the oldest
+ # secure version available: https://github.com/xml4r/libxml-ruby/issues/103
+ sed -i -e '/tc_html_parser_context/d' test/test_suite.rb || die
+ sed -i -e '/test_bad_xml/,/^ end/ s:^:#:' test/tc_parser.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/libxml extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/libxml V=1
+ cp ext/libxml/libxml_ruby.so lib/ || die
+}
+
+each_ruby_test() {
+ # The test suite needs to load its files in alphabetical order but
+ # this is not guaranteed. See bug 370501.
+ ${RUBY} -Ilib -r ./test/test_helper.rb test/test_suite.rb || die
+}
diff --git a/dev-ruby/libxml/libxml-2.8.0.ebuild b/dev-ruby/libxml/libxml-2.8.0.ebuild
new file mode 100644
index 00000000000..41a3830eb8b
--- /dev/null
+++ b/dev-ruby/libxml/libxml-2.8.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ruby22 → test suite hangs
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_NAME="libxml-ruby"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.rdoc HISTORY"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby libxml with a user friendly API, akin to REXML, but feature complete and significantly faster"
+HOMEPAGE="https://github.com/xml4r/libxml-ruby"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm hppa ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${RDEPEND} dev-libs/libxml2"
+DEPEND="${DEPEND} dev-libs/libxml2"
+
+ruby_add_bdepend "doc? ( dev-ruby/rdoc )"
+
+all_ruby_prepare() {
+ # Remove grancher tasks only needed for publishing the website
+ sed -i -e '/grancher/d' -e '/Grancher/,$d' Rakefile || die
+
+ # We don't have the hanna template available.
+ sed -i -e 's/hanna/rake/' Rakefile || die
+
+ # Remove rake-compiler bits since we don't use it
+ sed -i -e '/extensiontask/d' -e '/ExtensionTask/,/end/d' -e '/GemPackageTask/,/end/d' Rakefile || die
+
+ # replace ulimit -n output as it does not work with Ruby 1.9
+ sed -i -e 's:`ulimit -n`:"'`ulimit -n`'":' test/tc_parser.rb || die
+
+ # Avoid test failures with libxml2-2.9.2 since that is the oldest
+ # secure version available: https://github.com/xml4r/libxml-ruby/issues/103
+ sed -i -e '/tc_html_parser_context/d' test/test_suite.rb || die
+ sed -i -e '/test_bad_xml/,/^ end/ s:^:#:' test/tc_parser.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/libxml extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -C ext/libxml V=1
+ cp ext/libxml/libxml_ruby.so lib/ || die
+}
+
+each_ruby_test() {
+ # The test suite needs to load its files in alphabetical order but
+ # this is not guaranteed. See bug 370501.
+ ${RUBY} -Ilib -r ./test/test_helper.rb test/test_suite.rb || die
+}
diff --git a/dev-ruby/libxml/metadata.xml b/dev-ruby/libxml/metadata.xml
new file mode 100644
index 00000000000..ee10e6e2ad6
--- /dev/null
+++ b/dev-ruby/libxml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">xml4r/libxml-ruby</remote-id>
+ </upstream>
+</pkgmetadata>