summaryrefslogtreecommitdiff
path: root/dev-ruby/little-plugger
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/little-plugger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/little-plugger')
-rw-r--r--dev-ruby/little-plugger/Manifest1
-rw-r--r--dev-ruby/little-plugger/files/little-plugger-1.1.3-ruby20-spec.patch11
-rw-r--r--dev-ruby/little-plugger/little-plugger-1.1.3-r2.ebuild30
-rw-r--r--dev-ruby/little-plugger/metadata.xml8
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-ruby/little-plugger/Manifest b/dev-ruby/little-plugger/Manifest
new file mode 100644
index 00000000000..abde34726d8
--- /dev/null
+++ b/dev-ruby/little-plugger/Manifest
@@ -0,0 +1 @@
+DIST little-plugger-1.1.3.gem 9216 SHA256 d7a3a4582a00ff65955eeded02c6d127f3858f4e101e2fe4c795c7423dd83d33 SHA512 dbfa4e39eb41143627d0affab789d925c5c9c45a7592002440c957009da1b452f8b35bc5cc45adb22e8cd6b05776321240a59eae2e834f0ca29f1a26f368f0f1 WHIRLPOOL 2d7f5389412ba4f3f294fda7ff78f48040f8f212c93ec34257b011099dbdfc4bbb2709af361462975248fc14a8ad7eaf3c740488a11f8b9b5b4cff51fd700a4e
diff --git a/dev-ruby/little-plugger/files/little-plugger-1.1.3-ruby20-spec.patch b/dev-ruby/little-plugger/files/little-plugger-1.1.3-ruby20-spec.patch
new file mode 100644
index 00000000000..71b9611da1f
--- /dev/null
+++ b/dev-ruby/little-plugger/files/little-plugger-1.1.3-ruby20-spec.patch
@@ -0,0 +1,11 @@
+--- a/spec/little-plugger_spec.rb 2013-12-03 19:30:13.104060898 +0000
++++ b/spec/little-plugger_spec.rb 2013-12-03 19:31:18.716236041 +0000
+@@ -18,7 +18,7 @@
+ it "generates a default plugin module" do
+ LittlePlugger.default_plugin_module('little_plugger').should be == LittlePlugger
+ lambda {LittlePlugger.default_plugin_module('little_plugger/plugins')}.
+- should raise_error(NameError, 'uninitialized constant LittlePlugger::Plugins')
++ should raise_error(NameError, /uninitialized constant (LittlePlugger::)?Plugins/)
+ LittlePlugger.default_plugin_module('process/status').should be == Process::Status
+ end
+ end
diff --git a/dev-ruby/little-plugger/little-plugger-1.1.3-r2.ebuild b/dev-ruby/little-plugger/little-plugger-1.1.3-r2.ebuild
new file mode 100644
index 00000000000..5976f97b6f5
--- /dev/null
+++ b/dev-ruby/little-plugger/little-plugger-1.1.3-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Module that provides Gem based plugin management"
+HOMEPAGE="http://github.com/TwP/little-plugger"
+
+IUSE="test"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+all_ruby_prepare() {
+ # Remove default metadata because it confused jruby.
+ rm -f ../metadata || die
+
+ epatch "${FILESDIR}"/${P}-ruby20-spec.patch
+}
diff --git a/dev-ruby/little-plugger/metadata.xml b/dev-ruby/little-plugger/metadata.xml
new file mode 100644
index 00000000000..15e105c467e
--- /dev/null
+++ b/dev-ruby/little-plugger/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">TwP/little-plugger</remote-id>
+ </upstream>
+</pkgmetadata>