summaryrefslogtreecommitdiff
path: root/dev-ruby/logging/logging-2.2.2.ebuild
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-06-09 06:54:43 +0200
committerHans de Graaff <graaff@gentoo.org>2017-06-09 06:54:43 +0200
commit3000c45b5e33bcd102d675ae8d0d715dc854aaf6 (patch)
tree40ad90c935646fe7b1a1f74c09e3d0a28b7b580d /dev-ruby/logging/logging-2.2.2.ebuild
parentb48b3d1cc2de4fac66782b3f053499fd2a4dfcb9 (diff)
downloadgentoo-3000c45b5e33bcd102d675ae8d0d715dc854aaf6.tar.gz
gentoo-3000c45b5e33bcd102d675ae8d0d715dc854aaf6.tar.xz
dev-ruby/logging: add 2.2.2
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-ruby/logging/logging-2.2.2.ebuild')
-rw-r--r--dev-ruby/logging/logging-2.2.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/logging/logging-2.2.2.ebuild b/dev-ruby/logging/logging-2.2.2.ebuild
new file mode 100644
index 00000000000..318abf74790
--- /dev/null
+++ b/dev-ruby/logging/logging-2.2.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+RAKE_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.txt README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Flexible logging library based on the design of Java's log4j library"
+HOMEPAGE="https://rubygems.org/gems/logging"
+
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/little-plugger-1.1.3 >=dev-ruby/multi_json-1.10"
+
+ruby_add_bdepend "dev-ruby/bones test? ( dev-ruby/flexmock )"