summaryrefslogtreecommitdiff
path: root/dev-ruby/metaclass
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/metaclass
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.xz
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/metaclass')
-rw-r--r--dev-ruby/metaclass/Manifest2
-rw-r--r--dev-ruby/metaclass/metaclass-0.0.1-r1.ebuild23
-rw-r--r--dev-ruby/metaclass/metaclass-0.0.4.ebuild24
-rw-r--r--dev-ruby/metaclass/metadata.xml8
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-ruby/metaclass/Manifest b/dev-ruby/metaclass/Manifest
new file mode 100644
index 00000000000..a5a08c83dc0
--- /dev/null
+++ b/dev-ruby/metaclass/Manifest
@@ -0,0 +1,2 @@
+DIST metaclass-0.0.1.gem 4608 SHA256 b4fd9b39a7d667da99733f9cab1bf48fc34e2ecea7cb8bbb3ec8fa177bd98a3b SHA512 a4e8a946b9e61e4f24b0fc41e7d8b1e43af669ae3975253935e99d80504438773918a920bb8b9e9be8c35c35e08bbca7147e56c86b74e853232e516949b6bff8 WHIRLPOOL 2449551574a8f1bad7a0b7b45ad127395491b6c6450dbb152eca3ec3ecb117bc6acd3e3de601cde2101ec682e0e78edf6826c3e06495ba9abbe4476c30594b19
+DIST metaclass-0.0.4.tar.gz 2482 SHA256 1437025471310a40194db801fd577970b22cfc967bf9ffd55edeee0df6b25862 SHA512 5f41fe3db9c682ab6ab01c737c8531d2b4c2fdbc0f35f8fc9f40ce09a84ddf0d442c17caa1c3e87bb2c5e4703556c5d50fd9f72434b89e03d163db375046f0a4 WHIRLPOOL dda8b1901c6642f4ed2f512ed66ccf03c1fcc29bba1fccce66b29340a45a40bd0e7b72047d60bcb8fbec5ff6ba6b55512fa19198f8a53fb6d7d922ac960cbf89
diff --git a/dev-ruby/metaclass/metaclass-0.0.1-r1.ebuild b/dev-ruby/metaclass/metaclass-0.0.1-r1.ebuild
new file mode 100644
index 00000000000..b8d43b102f4
--- /dev/null
+++ b/dev-ruby/metaclass/metaclass-0.0.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Adds a __metaclass__ method to all Ruby objects"
+HOMEPAGE="https://github.com/floehopper/metaclass"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/test_helper.rb || die
+}
diff --git a/dev-ruby/metaclass/metaclass-0.0.4.ebuild b/dev-ruby/metaclass/metaclass-0.0.4.ebuild
new file mode 100644
index 00000000000..467dd258bef
--- /dev/null
+++ b/dev-ruby/metaclass/metaclass-0.0.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+SRC_URI="https://github.com/floehopper/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+DESCRIPTION="Adds a __metaclass__ method to all Ruby objects"
+HOMEPAGE="https://github.com/floehopper/metaclass"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile test/test_helper.rb || die
+}
diff --git a/dev-ruby/metaclass/metadata.xml b/dev-ruby/metaclass/metadata.xml
new file mode 100644
index 00000000000..1a2f81d0097
--- /dev/null
+++ b/dev-ruby/metaclass/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">floehopper/metaclass</remote-id>
+ </upstream>
+</pkgmetadata>