summaryrefslogtreecommitdiff
path: root/dev-ruby/metasploit-credential
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2015-10-08 16:58:11 -0400
committerZero_Chaos <zerochaos@gentoo.org>2015-10-08 17:04:44 -0400
commit7c78113940300a9ca123133d2eb69647d5220300 (patch)
treeb13c86ed3c5bf5c64ad779e0adf55058d9c517cf /dev-ruby/metasploit-credential
parent0d48e510226ea66c31aa9a947bc10359de99e291 (diff)
downloadgentoo-7c78113940300a9ca123133d2eb69647d5220300.tar.gz
gentoo-7c78113940300a9ca123133d2eb69647d5220300.tar.xz
dev-ruby/metasploit-credential: bump and fix deps
Metasploit::Credential::SSHKey depends on 'net/ssh', but metasploit-credential does not declare the net-ssh gem as a runtime dependency because metasploit-framework includes its own version of 'net/ssh' which would conflict with the gem. Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ruby/metasploit-credential')
-rw-r--r--dev-ruby/metasploit-credential/Manifest1
-rw-r--r--dev-ruby/metasploit-credential/metasploit-credential-1.0.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/metasploit-credential/Manifest b/dev-ruby/metasploit-credential/Manifest
index 948e652c654..208f07e5a2b 100644
--- a/dev-ruby/metasploit-credential/Manifest
+++ b/dev-ruby/metasploit-credential/Manifest
@@ -1 +1,2 @@
DIST metasploit-credential-1.0.0.gem 101888 SHA256 086cb65295f1294c213138bd2a9f2f727d945b90837a7e877b22bc6a47fe33f6 SHA512 4af09458a83d9425c5bfd744bc3f366c08d9175b4c303fa9ff53dd3f2163ba654748ea883d22f069e3b3be1218b57afe909f7ba31feb54c0b7ff781af8d5e631 WHIRLPOOL 506c707f3e1be0e90fad02397a34c70e44d1f423b5909d9f61152e2a4e929eadccf0736ec607c569fe75fff24c6003243d0a9a288979450b8c52d5f1feba1f6d
+DIST metasploit-credential-1.0.1.gem 101888 SHA256 e37e02d962a00733f8a82d486ee8b38aa287503d61812fba9cca05e834d873ca SHA512 e2d77cf1af9b9f7c09c3b98fc61c032dd5890bc019d09e208706ea93560402c82abc5a3dbc178442fbc1597d9e43e8a98f76bdb71fe470e7091d5e79bb30660f WHIRLPOOL 15b568fa61f64d895df9a7c5c04ae22232f9d805fca71c565fc2db871b4c443c163a922d52faa1953b3fadb157d71a6ea1866d2f740eff0db3262d78066c812e
diff --git a/dev-ruby/metasploit-credential/metasploit-credential-1.0.1.ebuild b/dev-ruby/metasploit-credential/metasploit-credential-1.0.1.ebuild
new file mode 100644
index 00000000000..15376438081
--- /dev/null
+++ b/dev-ruby/metasploit-credential/metasploit-credential-1.0.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_EXTRAINSTALL="app config db spec"
+
+DESCRIPTION="Code for modeling and managing credentials in Metasploit"
+HOMEPAGE="https://github.com/rapid7/metasploit-credential"
+SRC_URI="mirror://rubygems/${P}.gem"
+
+LICENSE="BSD"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/metasploit-concern-1.0.0:1.0
+ >=dev-ruby/metasploit_data_models-1.2.0
+ >=dev-ruby/metasploit-model-1.0.0
+ dev-ruby/rubyzip:1
+ dev-ruby/rubyntlm
+ >=dev-ruby/railties-4.0.9:4.0
+ dev-ruby/pg"