summaryrefslogtreecommitdiff
path: root/dev-ruby/metasploit-payloads
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2015-11-06 20:06:56 -0500
committerZero_Chaos <zerochaos@gentoo.org>2015-11-06 20:17:51 -0500
commit40676a444ddaff02af516f38b5c84a974644bad2 (patch)
treea4bac348d0c23886e257f887596654cfe73665d1 /dev-ruby/metasploit-payloads
parenta16b160f1893154607f64c44825c6763a2fc66cf (diff)
downloadgentoo-40676a444ddaff02af516f38b5c84a974644bad2.tar.gz
gentoo-40676a444ddaff02af516f38b5c84a974644bad2.tar.xz
dev-ruby/metasploit-payloads: re-add 1.0.15 for new snapshot
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ruby/metasploit-payloads')
-rw-r--r--dev-ruby/metasploit-payloads/Manifest1
-rw-r--r--dev-ruby/metasploit-payloads/metasploit-payloads-1.0.15.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/metasploit-payloads/Manifest b/dev-ruby/metasploit-payloads/Manifest
index 2a70295272d..a0a5ae32c46 100644
--- a/dev-ruby/metasploit-payloads/Manifest
+++ b/dev-ruby/metasploit-payloads/Manifest
@@ -1,2 +1,3 @@
+DIST metasploit-payloads-1.0.15.gem 5249536 SHA256 8d186c3bcf8a4537b9a96301e8cc0d847335d3cfa87ca5b2e88a6b2980eab240 SHA512 58afa5c4bc191a05e3ec009d94d40f2d9fc5a025962088845db14aefc410340fdc7b1e30f17c75936495a43fc99576d188960bc5755dbec434d7428fbbdd495a WHIRLPOOL d136642c1de9b18e652c421ad3b9fd859b8d8850dd539d66d4c8b410e09064d7872bc06c505b01d5389d1e2ebe22ed6b3c88aa3a0f08a1578f204201c24b3438
DIST metasploit-payloads-1.0.16.gem 11805696 SHA256 e127930c2b6cf09c91f2a2d7ef2a215aae2dee00172606c6b8644886b932301f SHA512 27f51db437f49d5685007e8a8762123890e6cce46b7465b2db3c070298e23bc4c440583c37da59b841a91deb100d47aa86db2d634f07ed212fbba11134c3fe47 WHIRLPOOL de81c9bbc1350621c8d3711fe29056a9116b7ffc63205f336d3efe22655777264c86790aec95d26af6858e516c0a667e368c021713ac87d8d20ff08b65e2bfd2
DIST metasploit-payloads-1.0.9.gem 5248000 SHA256 bd9eec335158dd25e579c680856f8c48aa9ba081a5d51d87a05dbb1e511087a3 SHA512 4c08284d4b1d667f545d97e879b2581830f34d42560ba6d6ed7adf32312adc841d5fdd8b55ab4e06a196d1e313fb44fbb861ccac7790e50f88260e2def0a76ed WHIRLPOOL a398dcad94b38626d4bd3d9980d05a24ccdbc12bbd2e902dd4f78c9bcd2cf4a26c76645d989a00aec69d041d9203c5ff31e0b0f948028ac6cd06ae724d573950
diff --git a/dev-ruby/metasploit-payloads/metasploit-payloads-1.0.15.ebuild b/dev-ruby/metasploit-payloads/metasploit-payloads-1.0.15.ebuild
new file mode 100644
index 00000000000..8360c06db03
--- /dev/null
+++ b/dev-ruby/metasploit-payloads/metasploit-payloads-1.0.15.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRAINSTALL="data"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Compiled binaries for Metasploit's Meterpreter"
+HOMEPAGE="https://rubygems.org/gems/metasploit-payloads"
+
+LICENSE="BSD"
+
+SLOT="${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#no tests
+RESTRICT="test strip"
+
+QA_PREBUILT="
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/msflinker_linux_x86.bin
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_sniffer.lso
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_networkpug.lso
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/meterpreter/ext_server_stdapi.lso
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/armeabi/libndkstager.so
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/mips/libndkstager.so
+ usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs/x86/libndkstager.so
+ "
+
+src_install() {
+ ruby-ng_src_install
+ #tell revdep-rebuild to ignore binaries meant for the target
+ dodir /etc/revdep-rebuild
+ cat <<-EOF > "${ED}"/etc/revdep-rebuild/99-${PN}-${SLOT} || die
+ #These dirs contain prebuilt binaries for running on the TARGET not the HOST
+ SEARCH_DIRS_MASK="/usr/lib*/ruby/gems/*/gems/${PN}-${SLOT}/data/android/libs"
+ EOF
+}